Uipath Robot Error - Invalid token specified: Cannot read property 'replace' of undefined

Hi all,

I’m facing some issues regarding Uipath Assistant. The following popup appears when a user logs in into the virtual machine → open manually the Uipath Assistant (since is not being launched automatically)

This happens when:

  • I log in into the virtual machine → open manually the Uipath Assistant (since is not being launched automatically)

Considerations:
*Studio/Robot Version: 2021.10.3
*Orchestrator Version: 2019.10.19
*Product Component Version:2021.10.3

Is there a way to solve this issue? Any help would be great!

Thanks!

Hi
Try reconnecting your robot with orchestrator and ensure if machine key is used it is mentioned correct

And have a view on this thread more ideas
UiPath Robot Error - Cannot Read Property xxx Of Null - #16 by xymanuel

Cheers @joaonuno.costa

Hi Palaniyappan, thanks for your answer.

We’ve tried disconnect and reconnect the robot to Orchestrator. The robot runs okay but the error message popups twice. It will go away if we click “Okay” twice and then everything works fine but the error message pops up again if we close the assistant and open it again.

Could this be related to an issue of some config files, since we updated the Uipath Studio recently to the latest version? Any thoughts?

Hi @joaonuno.costa

Could you confirm if the issue still persists or not ?

If yes, can you share the Diag Tool logs using below steps :

  1. Search for DiagnosticTool in your Start Menu, open it.
  2. Select the Studio/Robot option and go through the steps (next, next, next)
  3. Share with us the resulted .zip file?

Also, can you go to Assistant->Preferences and send us the information from here(as shown below) :

If issue is not occurring anymore, were there any steps performed in order to resolve it ?

Hi @sumit.vijay thanks for your suggestion and availability to help. I must say that this case was solved this weekend. The action was to update the orchestrator to a newer version (2021.10). So Studio/Robot, Orchestrator and Product Component have now the same version.

Thank you very much and I will keep in mind your suggestion for future issues.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.