UiPath, Jenkins CICD Pipeline Tutorial - Part 1

Hi anupam, getting the same error. Could u please connect once in linkedin. M not able to send u msg there.

Please do let me know

Hi @debashishforyou - looks like all Deba(va)shishes face this problem - Haha! Are you sure that your Jenkins ‘config.xml’ is correctly setup?

In @devashish1989 case, we resolved this problem by restarting Jenkins and trying again. Do give that a shot.

PS: I am unable to connect with you on LinkedIn - it requests your email address to connect with you for some reason:

hi Anupam,

my Linkedin mail id : debbelieveinurself@gmail.com

please connect once u r free, have some important things to know from you as I am new to Jenkins

@debashishforyou and @anupamck: made sure folder: C:\JenkinsRoot is there and config.xml has below values : <workspaceDir>C:/JenkinsRoot/${ITEM_FULL_NAME}/workspace</workspaceDir> <buildsDir>C:/JenkinsRoot/${ITEM_FULL_NAME}/builds</buildsDir>
Post which restart the Jenkins. Hopefully it should work.

1 Like


I am trying to do the same with a on-premises orchestrator. But getting this error for all the builds.
Failed to package project: Microsoft.Rest.HttpOperationException: Operation returned an invalid status code ‘BadRequest’

I am getting the above error only when I am enabling the option “Use Orchestrator feed when packaging libraries” in the Build section

I don’t see API Access in Community Edition Cloud Orchestator. ( Admin → Tenant).
Can anyone please help?

Yes - The UI has changed since then. You can find it under the arrow mark you have shown in your screenshot:

Hello @sarathi125 - Sorry for my late response here. I don’t have experience in trying this out with an on-prem orchestrator. Were you able to sort out this issue?

1 Like

Thanks, @anupamck.

Hi @anupamck ,

No, not yet.

@ThomasStocker - do you have a clue as to why this is happening?

Hi @anupamck, first of all thanks for your detailed post on CICD Integration.

Hi @sarathi125, I understand it’s a bit late, but the good news is, we were able to integrate it with the on-prem orchestrator. Please let me know if you still looking for the solution, by any chance.

Hi @anupamck

Thank you for such nice article. I am getting lot of help from this.

I stuck at point where Pipeline is getting build. I am getting following error when building pipeline -

can you please help me in this. Please refer attached Jenkin file, ignore file extension so share here I changed it to .txt, also in file Logical name, tenant name, folder name are marked by ‘N’, instead of actual names for post here Jenkinsfile - test.txt (2.8 KB)

Avinash Jadhav

Hello @Avinash_Jadhav,

I tried my best to replicate the error you are getting. I committed your own Jenkinsfile to the repo and ran the pipeline with my tenant details. However, it always worked for me. I couldn’t replicate this case.

The error message tells me that the pipeline failed to compile due to the commands UiPathPack and UiPathDeploy. Please confirm that the UiPath Jenkins plugin has been installed correctly.

@praveen_sonkusare also had this same problem. Were you able to resolve it? If so, could you post your solution here?

@ThomasStocker - Is this a known issue on UiPath’s side? I have received multiple queries about this already.

Hi @anupamck ,

I updated Uipath plug in to latest one v2.7.0 and made changes in Jenkin to add traceLevel. Now I am getting error as - WorkflowScript: 59: Missing required parameter: “entryPointPaths” @ line 59, column 17.
UiPathDeploy (
snap of error:

I followed steps mentioned here in article.
If you have time we can sync to get it resolved.


1 Like

@Avinash_Jadhav I think I found the solution to your problem - thank you for the hints your previous message provided :slight_smile:

I realized that I was using an older version of the UiPath Jenkins plugin. The newer version now includes more mandatory parameters, which were missing earlier.

Please make the following changes to your Jenkinsfile:

  1. In the UiPath Pack portion, include the additional parameter traceLevel: ‘None’ as shown below.
                   UiPathPack (
                         outputPath: "Output\\${env.BUILD_NUMBER}",
                         projectJsonPath: "project.json",
                         version: [$class: 'ManualVersionEntry', version: "${MAJOR}.${MINOR}.${env.BUILD_NUMBER}"],
                         useOrchestrator: false,
   					  traceLevel: 'None'
  1. In the UiPath Deploy portion, include the parameters traceLevel: ‘None’ AND entryPointPaths: ‘Main.xaml’
	                UiPathDeploy (
	                packagePath: "Output\\${env.BUILD_NUMBER}",
	                orchestratorAddress: "${UIPATH_ORCH_URL}",
	                orchestratorTenant: "${UIPATH_ORCH_TENANT_NAME}",
	                folderName: "${UIPATH_ORCH_FOLDER_NAME}",
	                environments: 'DEV',
	                //credentials: [$class: 'UserPassAuthenticationEntry', credentialsId: 'APIUserKey']
	                credentials: Token(accountName: "${UIPATH_ORCH_LOGICAL_NAME}", credentialsId: 'APIUserKey'), 
					traceLevel: 'None',
					entryPointPaths: 'Main.xaml'

With these changes, your pipeline should spring to life. I will also update this post to include this changes.

FYI - @praveen_sonkusare - This should also solve the problem you had.


Thank you @anupamck !!

Issue resolved. Able to deploy process to orchestrator now. Thanks for your help.

Now my next target is to have Test automation, i.e. test deployment. :slightly_smiling_face:


@anupamck Hi Anupam,

I didn’t see API Access Window in the license version of Orchestrator 2020.10.4 version.

and also how we can check whether the organization login is through Azure or normal

The UI has changed since that version. Refer to this reply UiPath, Jenkins CICD Pipeline Tutorial - Part 1 - #27 by anupamck and see if this solves your problem.

I don’t understand your second question. Can you please be clearer? Which login are you referring to?

Thank you for the step by step. One doubt I have - the part that references environments: “DEV”. I do not the “Environments” icon in cloud.uipath.com community Orchestrator. What should be done for this in the JENKINS file?