Uipath - Install MS Office OCR

Deguiluz
June 30, 2016 19:14 NONE
Hi All,

I´m trying to install the extension “MS Office OCR” but i can’t complete the installation, a pop-up appears with a message of installation failed.

Is there another option to install it?

Thanks

Lavinia Cojocaru July 01, 2016 21:13 Official comment
The MODI is a component of Sharepoint Designer 2007. You can directly download it from here: https://www.microsoft.com/en-us/download/details.aspx?id=21581

After you install it, you can restart UiPath Studio and MODI should be available.

1 Like

Vincent Roussel June 30, 2016 20:03
Hi Deguiluz - do you have a screenshot of your error message ?

Deguiluz July 01, 2016 09:26
Hi Vicent,

Yes, this is the screenshot when i try to install it:

And this is the message that appears with the error:

I have administrator permissions.

Deguiluz July 04, 2016 10:41

Hi Lavinia,

Thank you for your reply.

I´m trying to install it but it’s imposible because i´m using Office 2013, so i´ve tried to install SharePoint Designer 2013 which is compatible with my version, but i continue receiving the same error from Uipath:

“MicrosoftOCR : Cannot instantiate the MODI object. Please install Microsoft Office Document Imaging.”

Haria, Rushabh July 12, 2016 11:59

Hi Deguiluz,

Is your MODI enabled in MS office?

If not then follow this steps and then check once.

1.Click on Start Button.

2.Click —> ‘Control panel’–> ‘programs’ -->‘program & features’ .

  1. Search for Microsoft office standard and hit a right click and select ‘change’.

  2. Select ‘add or remove features’ and click on continue.

  3. See the last option ‘office tools’ will be written and click on the expand icon (+) next to office tools.

  4. The screen will appear like this.

Click on the expand icon (+) next to ‘Microsoft Office Document Imaging’.

  1. Right click on Scanning, OCR and Indexing service filter and click on ‘run from my computer’.

4 Likes

Even after installing and restarting its not working.

Hello,

I’m using the 2016.2 version of UiPath and I didn’t had MS Office OCR installed on my VM. After reading this post carefully, I installed Sharepoint Designer 2010 (as I’m using Office 2010 instead) and I as far as I could understand on my Control Panel, I have Sharepoint enabled.

So, having said this, I installed Sharepoint Designer, I restarted UiPath and even the machine. I’ve no idea why I can’t see Microsoft OCR available. I need this to be able to pursue with the training on the UiPath Basic Training.

Anyone can give some light?

Cheers

1 Like

did you manage to find any solution for this?

Same problem to me. I have windows 8.1, office 2010 x64 installed, language installed, I installed Sharepoint Designer 2010 and OCR activated from Office, i don’t know what to do next…

2 Likes

Hello, someone please help ?

You need sharepoint designer 2007 for Microsoft OCR

Hi All, I too have faced the same problem and installed Sharepoint Designer 2007 as suggested, but no luck. Then I see, it’s mainly required Microsoft Office Document Imaging (MODI) to get Micorsoft OCR. Then I’ve uninstalled the Sharepoint Designed 2007 followed the below link(Method 2) and it’s working fine now. Now, I can see Micorsoft OCR

https://support.microsoft.com/en-in/help/982760/install-modi-for-use-with-microsoft-office-2010

4 Likes

Hi,
I’m facing a problem with microsoft OCR and I must use OCR to extract data in a process.
I’m trying to extract text from picture, but Extract text from screen activity always return an OCR method failed to scrape this UIElement.
image

MODI is installed and effective. I can use it in Onenote.

The machine on which this problem occurs is not connected to internet, can it be a reason of failure ?

Please, someone can help me?
I have no idea of what to do now