Uipath- Excel Formula With Write Cell Activity

Hi guys,

I’m trying to set some formula in Uipath Excel , but when I try to example formula like this it gives to me some error at below ;

My formula is like that ;

String.Format("=EĞER("“EMETİNSE(”“A2"”);"“EVET”";"“HAYIR”")"

My Error:

Could you please help me for exprassion format.

Best regards,

Thanks

hi @burakavuncu

looks like you’r ussing futher " than you need
please refer from that

best regards!

Hey man,

Its show basic formula. My formula should be like this , how can I write it ?

=IF(ISTEXT(A2);YES;NO)

Try this syntax

String.Format("=EĞER("“EMETİNSE(""A2"”);"“EVET”";"“HAYIR”")")

Regards
Gokul

Y are using Yes / No in the formula

Do need bool value try this formula

=IF(ISTEXT(A2),TRUE,FALSE)

Regards
Gokul

It’s not working mate. Is there any solution different ?

Thanks.

Can you elaborate your query little bit. If possible share the sample Input file @burakavuncu

Regards
Gokul

I’m gonna share my screenshot;

I’m trying to give this formula to excel cell.

Thanks.

Hi,

Can you try the following?

"=EĞER(EMETİNSE(""A2""),""EVET"",""HAYIR"")"

Regards,

Hi Mate,

I try it works but it write like this as you can see here there is “” on A2.

image

How can I fix it ?

Thanks.

Hi,

The following will work. Can you try this?

"=EĞER(EMETİNSE(A2),""EVET"",""HAYIR"")"

Regards,

It works, perfect !

But this time my excel gives error #AD? , do you know how can i fix that ?

image

Best regards,

Hi,

I’m not sure, but can you try English style as the following, for now?

"=IF(ISTEXT(A2),""EVET"",""HAYIR"")"

Regards,

1 Like

Thank you , it worked.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.