uipath.database.Activities - Row output Error

Hello ,

I am facing issue in uipath.database.activies

When I Run the query in query editor My Output Results: 10,000+ Records

If I Execute the same query in UIPATH activities My Output Results: 100 only

is there any option available in connection wizard to increase the LIMIT so that I can get the Exact Results

In Addition: I have tried to change the Fetch Row in advanced Wizard , That didn’t work well

Kindly Help us :slight_smile:


Hi @Viswanathan_A_M,

Welcome to community.

Are you sure about this? If you did not set a limit in the query you sent, such a situation should not exist. Maybe If you throw it into a table and check it in debug, it shows max 100, try printing it in an excel, then you can see the real number.

Can you share a screenshot?


1 Like

I printed in CSV file also , I still face same issue @muhammedyuzuak

It prints only 100 records from Database

I’m not familiarized with OLEDB, so this is as good as I can go.

Set “Fetch Rows” to 0, according to the documentation that will turn off the pre-fetch feature. However, consider the recommendation is to distribute it in batches, they suggest something between 50 and 200 rows as it may decrease performance. (I see your fetch rows property is set to 100) A few resources below:

1 Like

Nope , It didn’t help actually :frowning:

1 Like

@Palaniyappan - Could you please help on this ?

Found the Error - Its a Driver issue

Issue has been resolved Thank you so much for your support @Edwin_Barahona @muhammedyuzuak

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.