Hi Team,

I am getting error while the process is executing in production.
Cannot set unknown member 'UiPath.Core.Activities.OpenBrowser.AutomaticallyDownloadWebDriver

Tried enabling the Modern Design Experience but still facing same issue. Kindly help me to resolve this issue.

Sneha A

Hi @sneha_arbole

Here are some steps you can take to resolve this issue:

  1. Update UiPath packages: Ensure that you have the latest versions of UiPath packages installed in your project. Go to the “Manage Packages” section in UiPath Studio and check for updates for all packages, especially the “UiPath.Core.Activities” package. If any updates are available, install them and try running the process again.
  2. Clear NuGet cache: Sometimes, issues can arise due to corrupted cache files. To clear the NuGet cache, follow these steps:
  • Close UiPath Studio.
  • Navigate to the following folder: %userprofile%\.nuget\packages
  • Delete all the folders inside the “packages” folder.
  • Restart UiPath Studio and try running the process again.
  1. Check project dependencies: If you are using any custom activities or libraries in your project, ensure they are compatible with the version of UiPath you are using. Incompatible dependencies can cause issues with the workflow.
  2. Verify the “Open Browser” activity settings: Open your workflow and check the properties of the “Open Browser” activity. Look for any unusual or unsupported settings. For example, the “AutomaticallyDownloadWebDriver” property might be set to a value that is not recognized in your current UiPath version. Try removing or adjusting any such settings that might cause conflicts.
  3. Check for Studio profile settings: If you have enabled the “Modern Design Experience,” double-check that all settings and preferences are correctly configured in the “Studio Profile” section.
  4. Reinstall UiPath Studio: If none of the above steps work, consider reinstalling UiPath Studio. This can help resolve any configuration issues that might have occurred during the initial installation.
  5. Contact UiPath support: If the issue persists, consider reaching out to UiPath support for further assistance. They can provide specific guidance and solutions based on your environment and workflow.

Hope it works!!

Hi @sneha_arbole

Update all the dependencies.
Try clearing the .nuget packages cache by:

  1. Close UiPath StudioX.
  2. Navigate to the following folder: %userprofile%\.nuget\packages
  3. Delete all the folders and files inside the “packages” folder.
  4. Restart UiPath StudioX.

Hi @sneha_arbole

Check on this document



after trying with all the above steps now processes are not executing in server