Uipath Community Edition - After Uipath update, the Uipath update services stays & Uipath assistant don't start

Every time UiPath update, the UiPath update services stays & UiPath assistant don’t start.
I would need to restart the windows manually to get the UiPath assistant back up & running.
Is this a normal behavior?
(I would think that once the update is done, the UiPath assistant should be re-launched automatically so that user doesn’t need to restart the windows).
Or if it’s the issue, where should I start?
PS: It did happen with 2022.12 release on two laptops I own.

Hello @supakdee

As per my experience, there is no requirement to restart the windows instead the restart of UiPath studio is enough.

Today also I had an update, instead of windows restart studio auto closed and i restarted the studio.


Hi @supakdee

It is not normal behavior for UiPath Assistant to stop working after an update. It is possible that there is an issue with the update process or with the UiPath Assistant installation on your system.

To troubleshoot this issue, you can try the following steps:

  1. Check the UiPath Assistant logs for any error messages or clues about what might be causing the issue. The logs are usually located in the %LOCALAPPDATA%\UiPath\Logs folder.
  2. Check the UiPath installation folder (e.g., C:\Program Files (x86)\UiPath\Studio) for any files that might have been corrupted or deleted during the update process.
  3. Try repairing the UiPath installation by going to the Control Panel, selecting “Programs and Features,” selecting UiPath, and clicking the “Repair” button.
  4. If none of the above steps resolve the issue, you may need to uninstall and reinstall UiPath. Make sure to back up any custom assets or project files before uninstalling.

I hope it will work. Thanks!!!

Hi @supakdee,

Have you got it installed in Service or User mode?

If it’s in User mode, sounds like what you’re experiencing is expected behaviour;

Does closing UiPath Assistant (right click from system tray, Exit, then reopen) resolve this issue or does the issue persist after this and the only option you see is to reboot to get it working?

I tried to understand if it’s service or user mode.

Then I follow the below link and I found that service mode should be available only in the enterprise edition. I’m using community edition therefore, no service mode.

I will try to re-start UiPath assistant once the update complete next time and will share the result.

There is no repair button for UiPath.

I will try to understand better if re-start is needed or just re-launch UiPath assistant is sufficient during the next update.

Thanks for suggestion.

Hey @supakdee,

Sorry I completely skipped over the fact you’re on Community edition! For future ref, you can also double check if it’s in Service mode by looking at Services and seeing if UiPath Robot is there;

Next time an update occurs, I recommend as above, right clicking, select “Quit”, then reopen UiPath Assistant to see if this resolves it;


Thanks guys for the suggestions.
So far I uninstall & re-install UiPath.
I will observe the behavior in the next update and will share.

As I tried today, I can confirm that after update, the UiPath Assistant will close.

Once the update was done, I can manually restart UiPath Assistant without restart the windows.

It would be great if the UiPath Assistant can restart automatically especially on the unattended machine.