UiPath Add to Collection missing Work around & Append Items to Collection reliability

“Append Items to collection” for me is hit or miss. Sometimes it works. It requires initializing. When it does not work it seems that troubleshooting is hopeless. I saw a few posts saying that one can down grade UiPath.Systems.activities to v22.10.1 so i tried it. I was able to find the 'Add to Collection " from activity panel. I then tested the workflow and it worked as designed. I then went back to Manage Packages and upgraded my UiPath.Systems.activities to latest version. I tested the workflow and it worked. However the “Add to Collection” was no longer available in activity panel. I needed another add collection activity so I tried to copy the existing Add to Collection and configured it to allow it to be used for another collection. It worked. So the good news is you only have to downgrade once.

This may work or not for you. You would need to give it a try. but I know many have struggled with the unreliable Append to collection feature. I hope this helps those are are at a wits end trying to figure out why append seems to not always work. Test well. Good luck!


as an alternate we can use also direct statements instead
~ Adding 1 element
myList = myList.Append(myListValue2Add).ToList

~ adding more elements
myList = myList.Concat(myOtherCollection).ToList

And also we keep in mind:
to stay within LTS