UIPath 2022.4 Open aplication Activity - Could not find the UI element corresponding to this selector

I Can’t use Open Application activity in UIPath 2022.4. Every time i use it, i’ve got the folowing error:

Open Application ‘notepad.exe Untitled’: Could not find the UI element corresponding to this selector:

In this case i was trying to open notepad.exe.

Is there anyone facing the same problem?

Hello @jobs.tagif
Could you send a screenshot of what the error / context looks like ? I have that version and no error when using the Open Application Activity…
Do you use the classic Open Application Activity or Use Application/Browser ?

Bastien

@jobs.tagif

Welcome to our UiPath community.

Use Start Process activity and pass below path to open blank notepad file.

          C:\WINDOWS\system32\notepad.exe

Thank you for replying.

Iam using the Open Application.

Could you try to remove the “instanceAffinity=‘1’” by editing the selector ? Maybe the title part as well , as I think they aren’t needed.

That’s a strange thing. This field “instanceAffinity=‘1’” is not present in the selector . As you can see in the screenshot below.

It IS very odd , yes. However , you can already remove (at least )the title safely as it is overly specific (it may change depending on languages and doesn’t designate the application itself). You could also try without the cls one , which has little use as far as I can tell in opening an empty application.

Also , you can try using the UI Explorer and see the selector it itself uses , maybe there’ll be more on that there…

Thanks for the feedback.

SelectTest.xaml (5.9 KB)
I made the exact same one on my machine , please try to run it and tell me if you get the same error you have on your own.

Ok. I will try it out, then i’ll let you know the result. Thank you in advance.

Wich is your upath version?
I Downgraded from 2022.4 to 2021.4 and now it is working. I’m not say that the downgrad solved the problem, but now the openAplication activity is working fine.

I Downgraded from 2022.4 to 2021.4 and now it is working.

I am using the 2022.4 version too , but I have no problems on my side…

Hi @jobs.tagif

Have you downgraded the UIAutomation activity package and that solved the issue? If so, does it still reproduce on a newly created project with the latest version 22.4?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.