UiAutomation - Cannot select elements on a Java Desktop Application

I couldn’t select any of the elements in this Application.
This is the screenshot of the elements in question:

The Problem is I can only select the entire table

UiPath couldn’t select the nodes inside the table, the nodes on the tree. The box doesn’t want to go beyond that. I have tried using Export UI Tree activity from classic to extract the children so that I can get elements, but I noticed that there are no children.

<?xml version="1.0"?>




<Attribute aastate="enabled,focusable,visible,showing,focused,opaque,managesDescendents"/>

<Attribute accessibleClass="OverridenAccessibleJTable"/>

<Attribute accessibleFullClass="UiPathV8.CustomAccessible.Override.Swing.OverridenAccessibleJTable"/>

<Attribute app="javaw.exe"/>

<Attribute AppPath="C:\Program Files (x86)\Common Files\Oracle\Java\javapath_target_3922546673"/>

<Attribute baseClassName="javax.swing.JTable"/>

<Attribute checked="False"/>

<Attribute cls="IntecTreeTable"/>

<Attribute columnCount="6"/>

<Attribute editable="False"/>

<Attribute enabled="True"/>

<Attribute foreground="True"/>

<Attribute fullClassName="com.intec.components.tables.IntecTreeTable"/>

<Attribute hasFocus="True"/>

<Attribute hasTableAncestor="0"/>

<Attribute hwnd="0x2402B6"/>

<Attribute isMDIChild="False"/>

<Attribute javastate="enabled,focusable,visible,showing,focused,opaque,managesDescendents"/>

<Attribute PID="8780"/>

<Attribute position="(300, 145) - (1910, 181)"/>

<Attribute relativeVisibility="True"/>

<Attribute role="table"/>

<Attribute rowCount="2"/>

<Attribute subsystem="java"/>

<Attribute TID="8592"/>

<Attribute title="Intermediate - Itermediate - IME Prod"/>

<Attribute visibility="0"/>

<Attribute visible="True"/>

<Attribute wndExtStyles="0x100"/>

<Attribute wndStyles="0x16CF0000"/>





Can someone assist me on how I can target the elements on the tree like “OfflineMediation”

Thank you.

Hi @RobinsonFrancis, is there a public version of this application? The problem may not be easy to solve. I see the rowCount attribute is equal to 2. Maybe the children cannot be selected individually (using the Indicate element functionality), however, can you try expanding nodes in the UiExplorer tree and see if they are accessible? You may be able to get a selector from there and use it in future automations.

Hi @RobinsonFrancis ,

Have you tried installing the Java Extension and checked if it is able to identify the elements ?