Type special characters in typeinto text box

i need to enter !@#$% this type of special characters in my application , i am trying to use with type into activities but it is not working please help me anyone.

Thanks in advance

Hi @vinay1,

Check the properties of the activity, for example I think that if the SendWindowMessages property is checked, the text !@#$% will be typed like !23$%.


1 Like

@vinay1 please uncheck send windows messages and check simulatetype and try

hi pathrudu ,

Please look in to the above screen here i need to enter tht special character value i have tried by checking the properties what you have suggested. it is not working.

Thanks in advance

hope its a terminal emulator Please check weather window is active or not. and also try targeting location by clipping region.

if not working, check with terminal activities is there any option. i cannot give any info about terminal activities as i haven’t used them

please check and confirm me

Thanks susana,

I have tried with the properties it is not working , actually i am trying to enter text value in putty terminal.

Hi, I have the same problem here. My scenario is when I using activity “Type Into” to Notepad, and the char is not string (like a, b, c, etc) but special char like : [, ], %, $, #, etc. It always get error : RemoteException wrapping UiPath.Core.ElementOperationException: Special keys syntax error. Encountered invalid special key action at text position: 2. —> RemoteException wrapping System.Runtime.InteropServices.COMException: Special keys syntax error. Encountered invalid special key action at text position: 2.
at UiPath.UiNodeClass.WriteText(String text, UiInputMethod inputMethod)
at UiPath.Core.UiElement.WriteText(String text, InputMethod method)
— End of inner exception stack trace —
at UiPath.Core.Activities.ObsoleteTaskAsyncCodeActivity`1.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Please somebody help me, thank u before.

@dedi.sadikin - you just have to escape it with the same character once…

like : [[

Please below…




Thank you for your help, but I am using activity from GetOutlookMailMessage → TypeInto : Notepad, so I should copy the same excatly like in my email Outlook. I want to get Subject Email. So, we can not using “[[” right? Because we get exactly the same value from Outlook , except in UiPath posible to add some code custom. Sorry I am beginner in UiPath, is it posible?
But, good news is, I have workaround for this issue, I am using BuildDataTable and AddDataRow for get data from Outlook, copy to Excel not Notepad.
Thank you for your answer @prasath17

1 Like

You could copy the text, send it to the clipboard and then Send Hotkey ctrl-V to where you want to paste it.

1 Like

Try setting the SimulateType property of the TypeInto activity to True.