Type into not working in Background

Hello friends,
@rkelchuri, @Rammohan91, @balupad14, @Dominic, @vvaidya, @MAHESH1, @ClaytonM,

i need to save an Excel file and insert the path of the file with the Type into activity.

This activity doesn’twork with locked screen, and also if I use the Send Window message or Simulate.
How can I solve the problem?
Are there also some other activities?
Thank you so much,
It’s urgent.
Camilla :slight_smile:Main.xaml (25.7 KB)
type.xaml (8.7 KB)

Did you get a chance to use Set Text activity ?

1 Like

Thank you @rkelchuri.
The problem is that I should perform some actions on the excel file, then open the “Save file” box and save the file.
How to do thaT?
Cami :slight_smile:

Is it just the ‘Type Into’ that’s failing? if yes then as @rkelchuri mentioned you may give ‘Set Text’ a try. If not can you please mentioned where exactly its failing?

Rammohan B.

1 Like

Hello @Rammohan91,

I tried the solution set text but doesn’ work.

The problem is that the Bot cannot perform the step in which it should write in the combobox when the screen is locked

Can you please help me in solving the issue?
Sorry for the disturb @Rammohan91
Thank you,
Cami :slight_smile:

If I remember right, the Import Text Dialogue in Excel is not supported by “SendWindowsMessage” or “Simulate Click”. This should be shown by running from Studio though, but if it worked from Studio, then I am unsure.

1 Like

Hello @ClaytonM.
Thank you so much.
In fact the Import Text Dialogue in Excel doesn’t work for me if I check the boxes of “SendWindowsMessage” or “Simulate Click”.
Can you please help me in finding a way that works also with locked screen?
Thank you so much for your precious help,
Cami :slight_smile:

Hi @Camicat,

If you want to have this working with the Screen locked (Background automation), You need to use simulate clock as you said.

The combobox itself do not support Simulate click, however, its “Edit” children does.

The following selector will work fine

<wnd app='excel.exe' cls='#32770' title='Import Data' />
<wnd aaname='File name:' cls='Edit' />



Thank you so much @Florent_Salendres.
I’ll try your approach and let you know.
Thank you for your precious support :slight_smile:

This is gold!!
using Edit class worked perfectly well.
I was struggling with it for quite a while. Weird thing is ‘Type into’ worked with simulate option in the same process in previous step but it was a different window and by default the class was edit.
Thanks for your response for solving this mystery.