Type Into: Click with “Chromium API” is not supported for this element. Please use other input method

Hi all. I have an automation project I built that works perfectly fine in development but fails with the error “Type Into ‘Welcome to’: Click with “Chromium API” is not supported for this element. Please use other input method.” on the production machine. There was an older article with this same issue which turned out to be an issue with the element not being selected but in this case, as mentioned, it works in dev, just not in production. Any ideas?


1 Like

Hey @Justin_Lynch

Is that edge browser ?


did you select chromium API under input mode?

Hello @Justin_Lynch ,

Are you using the Application/Browser activity?Then you need to select Chromium API as the input method there also.

Hello @Nithinkrishna,

This is in Chrome with the Use Application/Browser activity and it is set to ChromiumAPI. Thanks.

Hi @jack.chan,

Yes, it is set to ChromiumAPI. Keep in mind, this all works fine on my development machine and nothing changes when I publish it to production. It’s only when I run it on my production machine that I get this error. And I am using the Chrome browser. I forgot to mention that in my original post. Thanks.

Hi @Rahul_Unnikrishnan,

Yes I am using Application/Browser activity with ChromiumAPI selected. It works fine in development but when it is published to and run in production (using all the same settings/activities), it doesn’t work. Thanks.

@Rahul_Unnikrishnan , @jack.chan , @Nithinkrishna

Thanks for your replies. Here are some additional screenshots. Again, all this works fine in dev so I should have to make any changes to get it to work in production, theoretically. I also made sure to check that the browser extensions were installed and working on production by reselecting the selectors on the prod machine, which select fine, but give the issue when ran.

Main Use Application/Browser

Type into activity showing using the same input method as the Use Browser activity.

Hello @Justin_Lynch ,

Are you using the same version of browser in both prod and in dev? Also did you tried restart the system after installing the chromium extension and to execute.

Hi @Rahul_Unnikrishnan ,

I think you are on to something there. My prod machine is actually running a newer version of Chrome.

Dev = Version 100.0.4896.127 (Official Build) (64-bit)
Prod = Version 101.0.4951.54 (Official Build) (64-bit)

That’s odd. I’d figure that versions x and later would support newer technologies but who knows :man_shrugging: ?! That being said, I switched to hardware keys for the time being as that works fine.

Ok…So hope your issue is resolved now?

Well, it’s resolved from the standpoint of my automation working in prod, but I’d like to be able to continue to use the ChromiumAPI in the future.

Hi @Justin_Lynch ,
Can you provide a recording of the whole problem, and, maybe, a sample of the workflow file?
I just tried the Type Into activity on the same webpage, on Chrome, with the same version, with Chromium API and I faced no issues.
Also, what is the UiAutomation version that you are using? Have you tried using one of the latest versions (even preview versions, just for testing) ?

Version 101.0.4951.54 (Official Build) (64-bit)

My dev environment is using Studio 2021.10.5 and my prod environment is using 2021.4.4, which is also the one running the 101 version of Chrome.

Here is a snippet of my workflow…
example.xaml (38.8 KB)

1 Like


Did you find a resolution to this issue, without having to change to hardware events?
I am having the same issue with Edge browser, its working fine in dev machine but not in prod.

No, I have not unfortunately. I’ll update if I do and please do the same. Thanks.

1 Like

Can you try to set the zoom page to 100%? If that is the problem, it will be fixed in the next stable release of UiAutomation.


Since you have mentioned about zoom page, I’m currently having difficulties with it and caused the bot to fail.

In my own machine, the zoom page is set to default(100%) and bot is running perfectly fine.
However, when I tested the bot in another machine with different zoom page(150%), field box can be activated but failed to perform the ‘type into’ activity.

Is this a known issue and can be fixed in the next version update?

Hi, yes, it is a known issue, and the fix will be released in the UiAutomation.Activities package 22.8-preview (I don’t have official timelines, but generally 8 means the 8th month, so probably to the end of August).

Thanks, glad to know that.

Is there any resources for checking reported issues?
This is certainly helpful…