Type Conflict (Data.table) x String

Good morning community, I’m a beginner and I’m doing my first project.

My task is to assign a new role to a series of user keys, these keys are removed from an excel file, until there are many problems, I was able to make the workflow work for 1 key, or the problem is running for a data set.
My specific problem occurs in the following situation:

Within a For Each self assures that the “value” variable is a specific iteration key, but when trying to assign this variable to a variable, an error occurs that indicates that a string type cannot be assigned a data.table.

Thanks for any input.

Image 1:




Hi @jesse.oliveira

You should pass row not valor

Ashwin S

May i know what is the datatype of variable valor and where it is from
Cheers @jesse.oliveira

I bring the data from an excel table, I used the excel scope activity to perform this extraction.

Valor está como DataRow.


@AshwinS2 I tried to assign directly, but gave error, I will try again.

I would strongly advise you too not start a real project without going through training first, you will end up losing a lot of your time trying to learn thing by yourself, if you are interested in free training for UiPath please go:
UiPath RPA Academy


I appreciate the nomination, but I already did the training offered on the platform, although it was about 2 months ago and since then I have not worked on anything related to UiPath.
I attended some classes again, however I still do not understand why this conflict, seems to me a small detail that I still can not identify.

1 Like