Dear all,

I’m following Level 1 and in lesson 12 working with Try_catch activity I found that cast to integer into try throw an error with triggering catch.

Even the solution attached make same error. Why try catch doen’t launch catch instance when error occurs? I tried with several types of exception in order to fix the error but doen’t work.

I can’t upload files to let others try.


Are you trying to convert a string form of number to integer? Example “2” to 2 ?
In which case, there may not be an exception.

Did you try to use Division by Zero to see if it throws an error you can catch?



In this case the exercise is trying to cast Excel cell values where some are numbers forms an other contain letters expecting to launch exception and execute activities placed in “catch”. When a cell value contain a letter, so interger cast can’t be done, exception is no treated into catch and stopping sequence.
This is a practice in Lesson 13 from Level 1 training. Even answer provided doesn’t work for me. I tried to use the most general exception handling to avoid problems.
I don’t know why exception is not treated

There’s a default setting in the newest version of UiPath which interferes with Lesson 13 Practice 1, to turn off this default setting go to your Debug view, open the Options dropdown, and de-select “Break on Exceptions”.

1 Like

Yes, that’s the issue. In Studio 2020.10.4 I had to turn on the button Continue on Exception on the ribbon in debug mode to have Catch step done.