Troubleshooting Guide: No Logs in Elasticsearch

How to resolve if there are No Logs in ElasticSearch?

Approach 1#:

Note:This will impact all the robots i.e. logs for all the robots will not be seen in Elastic Search.
The target defined is not correct, to validate target is defined correctly

  1. Search the parameter "target" in web.config
  2. Verify if the type is "Elasticsearch" as seen in below snapshot
  3. Verify the uri. defined for the target. uri represents the Elasticsearch URL
  4. Restart the Website in IIS.




Approach 2#:
Note: If a specific Robot is impacted, and logs are not seen in Elasticsearch

  • Log in to the impacted robot servers and clear the log file from the location C:\Windows\SysWOW64\config\systemprofile\AppData\Local\UiPath\Logs\execution_log_data and restart Robot service
  • Deleting the execution log data will cause permanent loss of logs for the impacted time frame.


Approach 3#:
Note: This applies if the disk space in Elasticsearch server on data drive is over 85% .

When the data node drive on Elasticsearch server reaches 85%, the node changes all the index to read-only and stops accepting new logs.
To fix this, follow below steps:

  1. Delete old index to make space for new logs
  2. Set read only property to false: do this by setting below property in elasticsearch.yml file
  • read_only_allow_delete: false



Approach 4#
Note: This applies if the tenant is renamed manually from database

If a tenant is renamed from backend by altering tenant name from "Tenants" table, the change will be effective in most areas of orchestrator. However logging uses a parameter called "LoggingIndex" from dbo.settings table in order to identify the index pattern. The logs will be sent to Elasticsearch with old name until the name is updated in dbo.settings table .