To read data in excel with maximum rows

hi,

How to read the excel file data with maximum rows of nearly more than 10000 rows. Using read range, excel scope, or modern read range activities, the BOT takes a longer time and does not move to the next step.
I tried “Append range”, and it works, but finally there will be empty rows in the middle of the sheet.
Is there an alternate option for this?

@Prasaanth_S1

Try using read range workbook…if you dont find this activity then click on activities → filter icon → show classic

That might be little quickers… and also in the modern activities try setting excel to invisible and run in background that might improve the speed

Cheers

1 Like

Check the data for any error or “NA” or data type mismatch on any of the columns

In my experience, there are cases where there are error on the data provided which can cause an issue./

Hi @Prasaanth_S1

did you try with XL activities?

Regards

1 Like

hi @Prasaanth_S1
Please use Excel as a DataBase, follow the below steps

  1. Open Excel file (Note - Excel file must remain open)
  2. In UiPath [Studio] Drag and drop Connect To Database activity
  3. Click Configure connection
  4. Open Connection Wizard
  5. Select Microsoft ODBC Data Source
  6. Use Connection String
  7. Click Build
  8. Go to Machine Data Source
  9. Click New
  10. Click Next
  11. Microsoft Excel Driver(.xls)
  12. Next
  13. Finish
  14. Give Some Data Source Name and Description → Select workbook → Select the particular excel file.
  15. Press Ok for all the Windows.

After this go to output property and create variable for Database connection
Next add Run Query Activity and pass the DataBase Connection variable in Existing Connection Property and give the query you want to run
Eg: “SELECT * From [Sheet6$]”

Hi @Prasaanth_S1 ,

  • One alternative option to read large Excel files with more than 10000 rows efficiently is to use the “Read Range” activity with the “Preserve Formatting” property set to false. This will reduce the read time and memory usage.
  • you can also try using the “Excel Application Scope” activity with the “Visible” property set to false. This will run the Excel application in the background and improve the performance.

Hi guys,

I got the solution for my issue and it works by using one modern activity “Find First/Last Data Row”.
Please refer to the below link.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.