"This control does not support data extraction" error

Hi there, I am new to Uipath and am testing out the software for my company.
Tried using the data scrapping wizard to retrieve information from a website, however encountered the error message “This control does not support data extraction”.
I have tried searching online for a solution, to no avail.
Please help!

data scrapping activity meant for only to extract structured data from your browser to a database, .csv file or even Excel spreadsheet.
If its not in tabular form then you can’t use Data Scraping .
Use screen scraping and then use string manipulation to get the required data out of it.

Hi ddapadil,

Thanks for the advise!
Somehow the data scraping wizard works on my chrome but not on IE.


When do you encounter the error? When creating the workflow or when executing it?
Does anything work in IE browser (like selecting objects inside web pages, or other automation) ?
Does this happen on a specific web site or on all websites?

What Windows and IE version do you use?
those were Qn asked by @adrian :slight_smile:

I got this same problem with Chrome, but works with IE. There is no error on execution, but when you try to do data scrape from Chrome it doesn’t recognize the table. It recognizes fine with IE. I build it with Chrome and it worked before, it just stopped working for some reason. Chrome version is the same and I tried to setup the plugin again. It didn’t resolve the problem, so now I am using IE for data scraping.

Problem solved! So, it is a setting in the Chrome add on. You go to the extensions setting chrome://extensions/, select Uipath, and put on settings ‘allow in incognito’ and ‘allow access to file URLs’.


i m trying to extract weeklly data table from below url.

but i m getting “this control does not support data extraction” error when using data scraping. Data is in table structured format still unable to extract using data scrapping…plz guide me how can i extract this data. Even i tried Screen scrapping still no success.
thanks in advance!!

@priyankak It means Data which you are trying to scrap is not in the structured format

Hello even I am also facing same issue .Someone please help me

Any luck on this .I am facing this issue with both Internet Explorer and Google Chrome. Please help.

Hey - see Trixy’s resolution above. It worked for me! :slight_smile:

@trixy I tried same solution. In mu UI studio, getting message like chrome plugin already installed. But in chrome no extensions are showing.

Hi ,
I am also facing the same issue , any luck on this ,Ui Studio gives the message as Plugin already installed , but No chrome extension could be seen , Any help is greatly appreciated, Thank you


It is working fine with Edge, but not with Chrome.

This worked for me! Thanks

Even i am facing issue with data scrapping, i tried in chroma as well as explorer, both not working for me.
I was trying on sites wikipidea and ecommerce site which was mentioned as an example in uipaths docs.
can anyone please help me on this!!!
As the solution suggested, i hace enable incognito mode and add url’s from chrome extension, Still it doesnt work for me!

This happended to me 3x times already. It seems the Chrome extension is kind of buggy, sometimes it just stops working? Or maybe it’s the data scraping macro, my extractors keep working, I just can’t make new ones…

  • My workaround is to remove the extension from Chrome and install it again via UiPath (Tools → UiPath Extensions).

  • Restarting my PC also seems to work, but that’s a hassle.