Third-Party WebApp, REST API Authentication Error

Hello everyone,

Could anyone help me with the following issue I’m encountering while using the ‘HTTP Request’ activity in the official UiPath.web.activities packet?

I’m following the instructions for using the HTTP Request Wizard, which seem fairly straightforward. The third-party API I am trying to access is for HyperScience and it uses OAuth2 as the authentication method, so I’ve filled in the wizard as follows using the authentication token provided by HyperScience:

When I go to Preview my results, however, I get the following error:

I am relatively new to REST APIs in general, but I have confirmed with HyperScience that the inputs I used in the Wizard (End Point, Authentication method, Access Token, and ‘Accept response as’ type) are correct. I also double-checked that the API was functioning correctly by testing it out using the exact same inputs in Postman. Using the exact same settings it worked fine in Postman (see image below), leading me to believe that I am either using the wizard incorrectly or that there may be an issue with the activity.

Any help/recommendations would be greatly appreciated!

Thanks,
Riley

Instead of preview request, try running the workflow asusual and try to print the status and result @BB-8

Just a try

Hi Hareesh,

Good thought! I had not yet tried that but should have. Unfortunately, it’s yielding exactly the same results as the Preview feature did:

Any other ideas?

Thanks,
Riley

It should work for sure if you are not missing anything @BB-8 :slight_smile:

But not sure why it is failing. Can you give a try in the new workflow?

Hi Hareesh,

I have triple- and quadruple-checked that my inputs for the UiPath activity and Postman are exactly the same, and I’m sure they are. The only required inputs in both situations are (A) the End Point, (B) the authentication method (OAuth2), and © the Access Token. I have copied and pasted the End Point and Access Token from Postman (where it is working) to the UiPath activity, but still cannot get this to work in UiPath.

I addition, I have tried:

  • Trying again in a brand new workflow
  • Using the activity both while connected and disconnected from Orchestrator
  • Installing UiPath on an entirely different computer and attempting to use the activity there
  • Attempting to use the activity from several different internet connections

Unfortunately all of these have yielded the same result. (E.g. “Authentication credentials were not provided. status_code 403”.)

Any other thoughts?

Thanks,
Riley

Can you post the screenshots of both the requests in postman and uipath @BB-8?

Hi Hareesh!

I believe I have screenshots of both the UiPath and Postman requests in my first post. Is there a specific different screen/view of the requests that you need to see?

Thanks for your help,
Riley

Sorry for the delayed response @BB-8

As everything seems ok, I was confused why it still throwing errors. Does the API needs the simple authentication also along with the OAuth token?

Hi Hareesh!

I don’t believe it should since this was not required in Postman, but I went ahead and tried anyway just to double-check. I entered my username and password for the HyperScience website and tried again, but still no luck. :confused:

Still in the dilemma @BB-8
Not sure why this is behaving so