The sheet does not exist

Hi all, I have problem with excel sheet, the notification show " The sheet does not exist"


But when i use sheet name “Sheet1” or “1” it worked. I already check the space too.
image
Please help me to fix it ! Thanks all !

I do not see any issue. Try attaching excel sheet and your xaml for the reference.
Or delete the Excel Application Scope and re-do the process flow.

Regards,
Karthik Byggari

Hi @marcus1206

Can you please check any leading or trailing spaces are present in excel sheet.

please share sample input file if you can. :slight_smile:

Regards,
Vijay Kumar C.

Hi @marcus1206,
It may be ‘Vietnam 1’ instead of ‘Vietnam1’.

Thanks and regards,
Despi

1 Like

As others have suggested, confirm the tab name is exactly the same as what you are trying to look for -

A few ways would be to use Get Sheets on the workbook or if you know that is the sheet name, try to rename the tab and copy that into UiPath.

Regards,

Tim

I had already check but it not work. I cannot upload my file because It contains client data.

Everything looks good so let’s rule out obvious things, are you sure your file path is pointing to the right file?

Of course, I checked, I don’t understand it just work when type the default value “Sheet1”

Any chance you could share the xaml file? Try re-doing the excel application scope?

Hello, I’m having the same issue, when I submit a file with a renamed sheet it does not work and the program is trying to read a sheet with the default sheet name in french (cause my system is in french) which is “Feuil1” though there is absolutely no sheet whith that name into my file:

Edit: before processing the excel file, my process retrieve it from emails in Outlook and save it locally, then if I try to read this saved file with an another process with exactly same instructions (so without retrieving it from outlook), it work!
Please help if someone knows, I really don’t understand :sob:

Re-edit: it worked! It was a stupid path error on my part, have a nice day you all :blush:

Yes it might be !

1 Like