Test result on Test manager still status pending

Hi, I am run execute test set on Test Manager. On Orchestrator run test and result status passed but Test result on Test manager still status pending.
Please help me.

HI @Ekanis_Kerdtubtim,

Can you verify if that test case in test manager is correctly linked with the automated test?

REgards
Sonali

Hi @sonaliaggarwal47

Thank you for response.
I make new linked between test manager and test set on Orchestrator is correct.
I can execute test from test manager to Orchestrator done. At Orchestrator execute and test result have passed but can not send back test result to Test manager.

Thank you.



Hi @Ekanis_Kerdtubtim,

Can you also check if you have also linked test case from studio to test manager before publishing to orchestrator?

Also, are you able to see an option to run test set directly from test manager? If yes, can you try that and see if status gets updated in both places.

Regards
Sonali

Hi @sonaliaggarwal47

Yes, I linked test case from studio to test manager before publishing to orchestrator and I can run test set directly from test manager. At orchestrator execute test and show test result but not send back test result to test manager. My test solution work on on-premise on vmware not cloud.

Regards
Ekanis.k

Hi @Ekanis_Kerdtubtim,

You mean all results getting updated in test manager as well for on-prem and just on cloud that part is not working?

REgards
Sonali

Hi!
Can you share a screen shot of the test cases which are in pending state on Test Manager`?

Kind Regards,
Gernot Brandl

Sorry, I just saw your screen shots.
Can you open the test execution which is in state “pending” and send a screen shot?

Hi @Gernot_Brandl

I can open test execution result “pending” but not have any test result return from orchestrator.

Regards
Ekanis.k


Hi @sonaliaggarwal47

All my work installed on VMWare is not done on the Cloud.
My problem is running on VMWare. It has nothing to do with Cloud.

Thank you for your response.
Ekanis.K

So, there is no information about an test cases in this test set on Test Manager. Since you are able to see results in Orchestrator, it seems to me that the link between test cases and automation is broken.

Please do the following:

  • Navigate to a test case in Test Manager which’s result should up here.
  • Switch to the Automation tab.
  • Click the “Unlink” button.
  • Open Studio
  • Open the corresponding test case in Studio
  • Select “Link file to Test Manager”
  • Select the right project and test case (the one you just unlinked from in Test Manager)

    try again

Hi @Gernot_Brandl ,
I have the exact same issue.
Test Case is linked:
image
Test Case is in Test Set:
image
Test Result is in Orchestrator:


Test Result is not synchronized with Test Manager: