Terminal Session Activity - CPF4169

Hello everyone.
first time using Terminal Session Activity for AS400.
and an error i keep encountering is the " CPF4169".
“Error message cpf4169 appeared during open of file cu970sfm (c s d f)”
what could be causing this and what fixes can you recommend?

1 Like

Hi @mayuyu,
Welcome to UIPath Community,
Hope below links will help you to the problem.



Still getting the Same error. Terminal is running and is able to login as well as display menu but when accessing menu items aforesaid error shows up. Tried 5250 then 3270. Tried resizing the screen too. None work

could you give a screenshot of the error? and the steps you performed

The terminal can be launched successfully. although everytime i try to access a menu item, error shows up instead

sample workflow

This is a known issue in regards to terminal screen sizing, cmiiw.
Unfortunately there isn’t a reliable fix for this issue.
If you’re press for time, you can use OCR based activity instead.

Also, this topic should be move to the Advance Section.

Hi @mayuyu,

Which Terminal Emulator app are you using and how do you connect? IBM EHLL or another provider?

Thank you.

(it’s indeed related to screensize, it has implication on the backend, as seen here https://itknowledgeexchange.techtarget.com/itanswers/cpf4169-error-appeared-during-open-for-screen-file/ , trying to understand the context in order to see if I can figure out a workaround. I’m afraid it’s especially problematic if you use “UiPath Internal” in Terminal Session).


If nothing else, you could just try to automate the Terminal Emulator App itself as explained in the pdf here:

1 Like

hi @mayuyu,
theses are some default screens which is comes in AS400. i saw your workflow. your in the correct track.now you need to use terminal activities and logic to perform your task

1 Like