"Table does not exist" in Get Table Range activity

I have a workflow that pulls a table range from a specified sheet in a workbook and then uses read range to read the table data. The workflow had been working perfectly fine but I added a new sequence before this one and for some reason it’s now giving me the error of “table does not exist” in the get table range activity.

I’ve double checked that the file path is correct and that the table does exist within the specified sheet. Any ideas on why uipath isn’t able to find the table? I’ve included my workflow below. Any suggestions would be greatly appreciated!

Fine
Kindly include a kill process with process name property as “EXCEL” before to this excel application scope
The reason is the table might be used in background
Or check with the table name mentioned (hope you are good actually with this)
Or if still the issue persists kindly recreate the flow freshly
Hope this would help You
Cheers @caitlinscott

I tried adding the kill process activity, this didn’t fix it. I also already tried deleting and recreating this section of the workflow but that also didn’t fix the error.

Not sure what you mean by “check with the table name mentioned”… I’ve opened the excel file and double checked that the table exists with the name I’ve specified in uipath.

Any other ideas on fixing the error? thanks!

Is the allocationPath mentioned is correct
Kindly check whether that file path has the table named “PivotTable”

Cheers @caitlinscott

Yes I’ve used a write line to test that allocationPath is the correct path, and I’ve checked when the error pops up that the table named “PivotTable” exists

Fine
Can I have a screenshot of that table in excel with table name if possible
@caitlinscott

It’s showing that both the sheet name and table name are “PivotTable”

SOLVED: I realized that I hadn’t selected the “IsPivot” property of the get table range activity, once I selected this the workflow worked perfectly!

1 Like

Great
Cheers @caitlinscott

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.