System Exception in Process Transaction State adds the same Transactions again and again to Queue from Init State


I got this scenario. I have a use case developed in RE Framework. In init state it takes data, do some filtering and add some transactions to the Queue.

In process transaction state, it performs couple more validations. If the validations are success, it closes the transaction in the application or else it will leave open and goes to other transaction.

In QA testing the above usecase is successful. When we did testing in PROD. Because of 2 particular transaction, we are getting system exception in Process transaction state when doing the validations.

So because of the system exception the bot goes to init state again, close all applications, relaunches them and again add the same Transactions to the Queue and it builds up the queue again and again

The system exception occurs at random point in the process Transaction state.

What is the fix for this ??

For example:

Think I got 20 transactions after filtering from init state to orchestrator queue.

process Transaction state started to get Transaction from queue one by one. Let The beginning 4 transaction are business failures.

At the 5th transaction the bot encountered system exception in process transaction state. So now the bot goes to init state closes, opens applications, and adds the same 20 Transaction again to the Queue.

Now the queue have earlier 15 +20 which makes the queue 35.
Think Again at 5th Transaction bot will encounter system exception. Now 30+ 20 new one makes queue 50, this keep on happening. What is fix ?


Place your Queue adding logic inside the First Run of the Config File

I believe you placed the logic outside of the IF Condition, so if you place inside the Config if First Run, then it will not try to reload the queue

Mark as solution if this helps


Thanks Srinu. You made my day!!! It worked. Many Thanks bro. They queue adding workflow was outside of first run. I changed it and its working well now.



I am glad that it worked

Mark as solution if this helps


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.