Submitted successful results of Generate Yearly Report. But Failed--UiPath Academy pls Help!

Hi There
The Generate Yearly report assignment has been successfully completed by me and I uploaded the results but I get 0 out of 100???

  1. I zipped the code base of both Dispatcher and Performer.
  2. The queue in m orchestrator had 13 items. All 13 items have been processed
  3. 13 yearly reports with the proper naming conventions have been created in Data\Temp. Zipped them also
  4. All the 13 records statuses have been changed to Comlpleted.
    After many iterations, It took such a long time! Why did I still fail?
    I took a screenshot of the successful output log too.
    Please suggest what I must do. I cannot do this whole thing again!!
    Request someone from UiPath Academy to answer

Are you updating the comments with uploaded ID for all 13 work items?

Please check.

Karthik Byggari

Yes Karthik.
All the items have the comments updated with the required information:
Below is the sample of comments and status for one such item:

ACME System 1 - Work Items

WIID: 818044
Type: Generate Yearly Report for Vendor
Status: Completed
Date: 2018-04-20
Comments: Uploaded with ID : 459488695b1867c2bcad43d3b8ba7cd

Thanks for the response. Please let me know what I should do to fix this?

As per the walkthrough document, does the comments include colon (:). Please check.

You have to update Uploaded with ID 459488695b1867c2bcad43d3b8ba7cd

Karthik Byggari

1 Like

The walkthrough does not include a colon!!
Just saw that. OMG. You could be right!
Will execute again and upload.
Thanks a lot Karthik!

1 Like

Hi Karthik
This is the 4th time I am running the flow. It executes few items and suddently it stops at any random item.
The error is like this
Get Text ‘Static’: Cannot find the UI element corresponding to this selector:
This did work for few items but randomly stops at some item. Why so?
Should I redo the file and execute the new code?
Any help is appreciated.

Can you please check or debug the output window which activity is throwing the error. Then you can easily fix it.

If the previous post got solved your problem mark the post as solution. Thank you.

Karthik Byggari

Hey Karthik
I guess the problem is with my PCs virtual memory allocation . Because the error comes randomly. Sometimes for the very first item, sometimes after 6 items are processed successfully. So problem is not with the workflow. ( I did the UploadYearlyReport.xaml file all over again and executed).

And this problem comes only at one place- at the time of uploading the merged excel file ( and particularly if any of the .csv monthly report is over 200 KB) The average size of the monthly .csv file is around 115 to 150 KB. Those all download fast and merge well and the yearly file for that TaxID processes.
But if any of the monthly report is bulky for a TaxID, I think that merged file fails to upload.

Its my bad luck that the one and only one workflow which executed all the 13 items without issues had the semicolon and I failed!

I tried changing the settings in the Uipath config file and increased the memory from 10MB to 20 MB.

Now to execute and check it, my assessment is pending evaluation since last 12 hours( I uploaded my latest one which had 6 out of 8 items executed, the 7th one failed with above error. I am hoping to atleast pass but it is not evaluated yet so I cant reset my data)

And by the way, I guess your semicolon catch makes sense and I made the change and uploaded . If I am marked correct for the processed items at least then I know your suggestion is right and I will surely mark the problem solved.
Please let me know what you think about my understanding of the memory issue.


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.