Studio Zoom - why does it "modify" the project when zooming?

This is a minor inconvenience I admit but it is a rather persistent and irritating one.

QUESTION: Does Studio have any means of setting a default Project level Zoom level ? Like say “75%” ?

Back to this original question - Why does Studio zoom modify a xaml file ? By modify, I mean zoom makes Studio auto-adjust transition lines. I like them where they are but I put them there !! :slight_smile:

Like this in Main.xaml - I got from this:

Zoom in using roller middle mouse and it goes to this:


This visually disrupts the “flow” of the workflow. It makes Flow Diagrams “flow” less consistent and at times you have to move transition lines around - after zooming or something. Very irritating.

I have learned I have to put Comment Activities are transition line anchors to prevent Studio from auto-determining where transitions line go.

@riverrat437 Yes you can set zoom level in the studio


You can select zoom level from the drop down or can enter manually as well

Also, the default zoom for studio is 100% which is so flexible in developing the code. While showing the demos if you want you can reduce the zoom level, that enables the users to view the complete framework

Thank you for the reply.

Yes, I understand the two means of changing Zoom. That one you indicated and the middle mouse button. But neither setting is permanent - close the xaml file and reopening it and you are back to 100%. My question still stands.

100% is not my preferred zoom setting. 75% is. I always change to 75% zoom for all my projects. Since Studio has no apparently “project setting” for zoom, I have to change it every time I open a xaml file in a project.

And why does “zoom” tend towards transition line “adjustment”. IMHO that should ONLY happen when I physically drag an activity around in a State or Flow Diagram.

No solution provided.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.