Studio - Analyze Project: Error Could not load file

Hello, while Analyzing Project in UiPath Studio 2019.10.1 ERROR appeared:

Error Could not load file C: \ Users \ *** \ Documents \ UiPath \ *** \ Workflow.xaml.

Following the message, I tried to rebuild the workflow in the hope that it would be fixed.

It turned out that the workflow is good and the “Image Exists” and / or “On Image Appear” activity is responsible for the error message.

Please verify BUG.

2 Likes

Kindly have a view on this thread

Cheers @Adrian_Star

Thanks for replay. In my case I have all packages up to date:

Workflow is working, project is working, but Studio’s Analyze Project tool has errors.

The tool cannot open the workflow and analyze the content due to causing some inconsistency in the program through activities related to “Image”.

It looks like a UiPath Studio bug.

Hi,

I get the same error message:
Error Could not load file C:\Users\xxxx\Documents\UiPath\xxxxxx\xxxxxx\Framework\InitAllApplications.xaml
Workflow is working fine.

During UAT it turned out that the workflow works partly. When using invoke workflow in the project, the arguments enter, but the data on the OUT arguments does not go to a higher level. Unfortunately, I cannot opt out of Image Exists activity because the code selector is visible even when the POP-UP window on the system is inactive.

Has this been accepted as a bug or is there a workaround?
I am experiencing the same problem.

Problem
When using the activity “Image Exists” i get the Error message “Could not load File c:…\main.xaml”. (see screenshot below)
The Process runs perfectly without an problem when it runs in Studio.
It only becomes a problem when i want to publish it or run the analyzer.
Please find attached the Project file for verification.
Test_ImageExists.zip (13.8 KB)
Of course this is normally part of a bigger project which a isolated for illustration.

What i checked so far

  • All Dependencies are up to date (see screenshot below)
  • I already created a project that only consists of this activity. (see screenshot below)

System
uiPath STudio 2020.02.0-beta.108 Comunity License

Log
I have the folling Log entries in 2020-04-05_WorkflowAnalyzer_Execution.

12:33:30.2680 Warn Feature is not supported
12:33:31.0209 Error Object reference not set to an instance of an object.
12:33:31.1497 Error Object reference not set to an instance of an object.

I’m really looking forward for any hints on what is going wrong here, as i would like to use the orchestrator.
BUT with this error i am not able to publish the project.

***Project & Error Message: ***


Packages:

If anyone else might experience this as well…
After Re-Installing Studio and Robot it is working now.

I have the same problem. Reinstalling the studio did not solve the problem for me

@Adrian_Star How did you solve the issue?
Re-installing studio didn’t help.

Hi @magda, On UiPath Studio v. 2019.10.1 and v. 2019.10.4 I had this problem. On UiPath Studio v. 2020.10.4 the problem does not occur (with the same packages).

Do you use the “Image Exists” and / or “On Image Appear” activity in your workflow?
What version of Studio are you using.=? In which versions do you have UiPath packages?

Hi @Adrian_Star,

Thank you Adrian.

The file which could not be loaded contains “Image Exists”.
Our current studio version is 2019.10.1, we wanted to upgrade the studio 2020.4.1 (and here we have issue with publishing).

After Analyze Project the error is returned in both studios, but the project can be published with 2019.10.1, and the project can’t be published with studio ver. 2020.4.1 due to that error

We’ll try to upgrade studio to version 2020.10.4, the issue will not appear there.

Cheers!