Starting 'UiPath Studio Community' process using Command LIne


#1

Is it possible to run processes of ‘UiPath Studio Community’ from Command Line?

I could run ‘Community edition’ using the UiPath Robot successfully, but not sure if starting can be done from Command Line and also using the API (REST web service).

I do not find this file in my system which is required to run process -
“C:\Program Files (x86)\UiPath Studio\UiRobot.exe”

Are these features not available in Community Edition?


#2

You should be able to start from cmd line using Community Edition (see link below). You can even pass in arguments. Not so sure about starting with API - try @andrzej.kniola for that one :slight_smile:

https://www.uipath.com/kb-articles/start-process-from-command-line


#3

Thanks Richard for the reply.

I tried to run from the Command Line as mentioned but was not successful. There was no file called UiRobot.exe which is required to run processes from Command Line. Even I could not find the folder ‘UiPath Studio’ under C:\Program Files (x86). Not sure if this folder and file are not created for the Community Edition.


#4

CE is in a different location:
C:\Users\USER\AppData\Local\UiPath\app-xxx.yyyy.zzzz\UiRobot.exe
CMD (and task scheduler) should work if pointed to correct location.

RobotService API is legacy AFAIK and Orchestrator is the recommended way. This of course doesn’t work with CE.


#5

Thanks Andrzej.

Found the folder and the required file, but still not successful in running the process from CMD.

Every time it says ‘unable to find the specified file’. I checked the path and looked all fine.

Studio.Log:
[ERROR] [UiPath.Workflow.Logging.StudioTraceListener] [5] System.IO.FileNotFoundException: Unable to find the specified file.


#6

Hi @Nilabja.Saha,

Did you find solution or its working now using command prompt? I am getting the same error as “Unable to find the specified file”.


#7

Hi,

  1. Run CMD As Administrator
  2. Run the UiRobot.exe (this is optional)
  3. Move to folder where you have UiRobot.exe
    (generally it reside in “C:\Users\User_name\AppData\Local\UiPath\app-***>”)
  4. write UiRobot.exe -f or- file “FIlePath\GoogleSearch.xaml”
  5. It will start execution

Hope this will work for you.

Thanks
Vivek S.


#8