Start RPA with .bat file

Hi,

Our administration team starts a process with a bat file ant it worked until yesterday. See print from cmd below. The user don´t have the orchestrator and never had. We haven´t made any changes, it just stoped working.

How can we solve this?

Best regards,
Magnus (Sweden)

“C:\Users\wendyw\AppData\Local\UiPath\app-19.12.0-beta0061\UiRobot.exe” execute --file “D:\wendy\UIPath_Projects\Platform_Test\Robot2_NotePad\Main.xaml”

Type command from the above comment in notepad and then save that as .bat

You can find multiple folder in app data/uipath folder… Try with both the .UiRobot.exe files.
One of it will work…

Below for ref

Thank´s but we have already tried with both UiRobot.exe files without succeeding.

Our path points at the “.nupkg” file and yours is towards “Main.xaml” -file. -Is there a difference that doesn´t work for us? What do you recommend?

And can you tell me more about why we got the error message “Could not log in user to Orchestrator”?

Best regards,
Magnus

Yes…Robot looks for xaml file for running…You need to pass the path of Main.xaml for execution…
When we publish the package and use it with latest version on Orchestrator then by default xaml gets downloaded to the machine and runs those xaml on the execution…

Could not login user to Orchestrator might be issue with access. Please check user id and password…
If still does not work then disconnect the Robot and connect it again…

It’s working now when the user signed out from UI Path Studio X. I can´t understand why, but when the user is logged in it stops working. -Can you please explain?

Best regards,
Magnus