SQL Server Error : Invalid object name after successful connection test

Hi everyone,

During my last project I stumbled upon a problem with the data connection to the MS Access database.

The ‘connect’ activity results in a ‘test succeeded’ after configuring it with the connection wizard. But when I try to perform a query (“Execute Query” - activity) it results in “SQL Server Error : Invalid object name”.

I have already searched the forum and tried multiple possible solutions, such as: using [ ] brackets, specifying the tables, …

When I open MS Access on the same computer and run the query inside the program, it works without issues. Can someone explain the issue?

The computer I’m working on is quite restricted, with a lot of permissions, fire walls, … The problem might be situated there? If so, anyone an idea on how to solve it?

Any help would be greatly appreciated.

Thank,
jesse

arent you using the wrong drivers there? or is it normal that you see “sql server error” in a message while trying to connect to ms access?

Thanks for the reply, I’m using the UIPath.Database.Activities version 1.3.7369.25200 published on 3/5/2020. I think I already uninstalled and installed it to see if it solves anything.

the activities does not include the drivers you use…

But if I have the wrong drivers, would it work in the MS Access application on the same computer?

if you are using access to access the access data, then you are not using drivers :slight_smile:

Ok thanks, yes I’m using access to access the access database :slight_smile:
So you would suggest to upgrade all the SQL drivers on the computer to the latest ones?

If i understand you correctly, you are not using SQL Server, so no, im saying that maybe you are using sql server driver instead of Access ODBC ones…

Yeah you are understanding me correctly. But I didn’t mention but I use the Odbc driver to set up the connection, and then work with the connection string. Wouldn’t I get an error in the “connection” - activity already if that would be the case?

so you are doing like this?
image

Yes indeed, I set it up like that during the “connect” - activity, with the connection wizard. And I select the second option (microsoft ODBC Data Source).