Special letters not encoding in http request

Hi,

I am using a http request to send SMS through a SMS provider we have.

In Postman when I do the request the SMS can display the Danish letters (“æ” and “ø”) if I replace them with the URL encode for these characters (for example “æ” is “%e6”).

However when I do the same in Studio the http request is just displaying the url encode. If I don’t replace the special letters the SMS will just replace the characters with a space.

How do I encode my http request to be able to display these characters?

Thanks!

Hi!

You can use the following statement to encode your text as a valid URL:

System.Net.WebUtility.UrlEncode("æ")

You can check Microsoft documentation here

Hi,

Thanks, but this is not working for me either. Still outputs a space when I use this encoding. However I fixed it by having the parameters directly in the endpoint line instead of in the parameter collection, but I don’t know why this is working :wink: