SOAP request throws "Object reference not set to an instance of an object"

studio

#1

Scenario: I just dragged SOAP request activity, entered URL and clicked Get, I am getting “Object reference not set to an instance of an object” error the moment I click Get.


#2

Hi,
Looks like you haven’t passed any request method
HTTP Method: It’s nothing but the what type of HTTP request you wants to make to the service such as GET , POST ,PUT or delete.
For more info.



#3

Thank you! But the problem comes much before that, I know that once I type in my URL and click get, all the data will be populated. Then I can select methods.
But I am getting the error as soon I click in “GET”


#4

Hi,
Maybe the webservice that you are trying to access needs authentication. I tried also the link and is returning another error for me (but the error message could depend by the version of the web activities package)

Thanks


#5

I am also facing the same issue. “Object reference not set to an instance of an object”. Any ideas on this ??


#6

Any updates please ??


#7

Any updates on this issue ???


#8

Hi,
Maybe the webservice that you are trying to use needs authentication? This is my only thought as this time. Is very hard to identity the problem just from a generic error message. I think that is the reason why no one answered to you until now.

Thank,
Cosmin


#9

i have the same issue, i can read the WSDL with soapUi without problem, the WSDL is well formated and there is no authentication mechanisme

any idea?


#10

As a workaround, I can suggest you 2 approaches.

  1. Using a custom SOAP activity and invoke it from workflow. Below article will explain the steps to that.
    https://www.uipath.com/kb-articles/consuming-a-soap-service-using-custom-activities

  2. Use HTTP request instead, here you will need to build a custom xml and then send it to the service.
    HTTP Request: Endpoint = complete or part of a variable


#11

same issue when using soap request. I tried passing required auth also. Didnt work . Is this a product bug?