Simulate Click Check Not working

I think I had a similar issue. The robot that was working 2018.1.1 failed in 2018.1.3. I had to change all IE clicks from SimulateClick to SendWindowMessage.

Hello Dom,

Thanks for the suggession, but my project contains more than 100 click activities.
Is there have any other option.

Hi @vikrammahit,

Starting with 2018.1.1, you can change the properties for multiple activities at one time, by selecting all desired activities (by holding Ctrl while clicking activities). The shared properties between the selected activities will be displayed in the properties channel. Then you can, for example, check SendWindowMessages, and the change will be applied to all selected activities.

Hope this helps,


Hello Cyril_kuhns,

Thanks for sharing this helpful feature of UiPath 2018.1.1 with us.

My project consists of multiple xaml files, is there have feature of ui path for setting any control property on project level, so that will be more useful for us.

Guys can we gather more details about this issue. We are not able to reproduce it in our environment.

  • share a workflow
  • share logs (low level tracing)

@vikrammahit “Same project code is working on another system with same configuration and same ui path version.” can you please enable low level tracing and share logs ?


If you don’t know how to collect traces, please follow the steps in this post:

1 Like
  1. What IE version is used ?
  2. We need a screenshot with IE developer tools console after the issue is reproduced. Can anyone share this info ?

Hi Andrei,
I am facing similar issue of “Simulate Click” Check not working anymore.
IE Version : 11.1358.10586.0
OS Version : Windows-10 Pro 64 bit
UiPath : 2018.1.3

It seems the issue is fixed in 2018.2.0-beta.11.
I just tried today and Flow is working expected as it used to be prior to 2018.1.3 update.

1 Like

Hi Yogesh,

This issue was also fixed in our latest official release 2018.1.4:

Thanks for the update.

Hi ovi

am facing same issue in v 2019.1.0

Hi @balu

Could you share some details about your project? Was it working before and stopped?
Could you collect the information mentioned in previous posts of this topic? It would help debug the issue.

Sharing your problematic workflow would be helpful as well.

I have a scenario where I need to input the transaction code and search for it by clicking on button.

I use click activity by enabling simulate type in properties.

it worked fine for few transactions later it cannot click on specific button.

for work around I am using click text with send windows message which works but its slow.

Note : I am using these for sap internal web portal.

It might be that the simulate type will misbehave with some applications. Have you checked the Click activity with the send windows message option?

Yes currently using the same, working fine now.


Hi All,

I’m facing an issue with simulate click option enabled in all the click activity in the UiPath 2018.3.3 in Windows 10 OS. Please suggest a work around for this issue.


Work around for this is using type into “Enter/Space”. I have encountered some issues as well, but i already fixed it using type into’s.

If you don’t know how to collect traces, please follow the steps in this post

Is it safe to share those logs and traces on this forum or am I violating the general security rules of an enterprise?

Hi @Victor_Stanescu

I believe that for an Enterprise environment it might be safer to not post any logs on the Forum.
What you could do instead is:

  • send it in a private message to our @Forum_Staff with enough context (link to the original issue here on the Forum)

OR (even better)

  • if you have the latest Studio Community Edition, you could use the in-build report system to report the buggy behaviour and attach the trance logs as attachment :slight_smile:
    Please also mention the Forum topic in the description for maximum context.
    See this topic to learn more about that feature:
    #FeatureBlog - 19.7 - Send feedback or report bugs directly from Studio