"Side-by-side Configuration is Incorrect"

uiautomation
robot
error

#1

Hello Everyone!
I’v recently stumbled across UiPath and have fallen in love with it’s ease and power. I’m currently trying to run my macro through the command line for those that don’t have UiPath installed on their machines by making a .bat file, and a folder containing the UiRobot.exe and my .xaml project.

My problem is whenever I try to run this from the command line, I receive the error: “The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail.”

I am not running the Command Prompt as an Admin
I am referencing UiRobot by pointing at "%USERPROFILE%\Desktop\test\UiRobot.exe"
Same goes for the .xaml

Any Recommendations!


#2

Hi,

“C:\Program Files (x86)\UiPath Studio\UiRobot.exe”

/file:“C:\Users\Iordache Razvan\Documents\UiPath\OpenExcelApp\Main.xaml”


#3

All machines running robots need to have UiPath installed (currently full suite, in the future Studio or Robot at least).


#4

Yes Agree with pal @andrzej.kniola

Right now till 2016.2.** version even you only wants to use Robot service to run a robot then also it is required to install Uipath studio i mean all bundle and now from the next version onwards i.e. 2017.1.* You will be able to install separatly Uirobot service and will be able to use it without install the Uipath studio.

Regards…!!
Aksh


#5

Any word from the dev team or anyone else on when I can just use the Robot as a standalone?

Also any word on the error I’m getting specifically? I haven’t found anything here related to that.


#6

@Nick.Unger, I was having the same problem. At least on my system, UiRobot.exe exists in two places (neither in Program Files).
For me, it’s “C:\Users\Me\AppData\Local\UiPath\app-17.1.6435\UiRobot.exe” and “C:\Users\Me\AppData\Local\UiPath\UiRobot.exe”.

I got the side-by-side error just as you did when I ran “C:\Users\Me\AppData\Local\UiPath\UiRobot.exe” /file:“C:\Users\Me\Documents\UiPath\MyProcess\Main.xaml”

But, if I run “C:\Users\Me\AppData\Local\UiPath\app-17.1.6435\UiRobot.exe” /file:“C:\Users\Me\Documents\UiPath\MyProcess\Main.xaml” it works fine.

Hope this helps!
burque505


UiRobot Service is not visible in Services.msc
UiRobot.exe does not start
Side-by-Side configuration incorrect - SxS problem with UiPath Studio
"The application has failed to start because its side-by-side configuration is incorrect"
#7

Thanks a ton,this solved the problem,many thanks,i indeed had 2 files,when i ran the second file it worked


#8

I think after every update everyone is facing this issue as the Uipath is creating separate Uipath studio and and Uipath robot inside the Uipath Version folder for eg app-18.1.0,app-17.1.6589

Since my old batch file was pointing at robot path inside the version folder “app-17.1.6589”.still I was not able to run the bot through the bat file.

when i changed it to “app-18.1.0” it worked just fine.