Sharepoint List activities - Space is removed from headers

I’m getting a SharePoint List with the activity:
Sharepoint application scope → Get List Items

What is weird is that space is removed from all the headers, e.g. “Link 1” turns into “Link1”.
Is this a known bug?
Spaces in the column values are still there.

UiPathTeam.SharePoint.Activities.Lists.ReadListItems v1.7.0

1 Like

Hi @Ferdinand,

+1 to the Issue you mentioned. However here is what I did as a workaround. Write the DataTable to an excel sheet placed in a temp location using Write Range Workbook Activity (Add Headers - Unchecked), Read the same excel sheet with Read Range Workbook Activity (Add Headers - Checked) and then delete the excel sheet. This way you get the headers as exactly as you want them to be.

Hope that helps !

Thanks & Regards,

1 Like

Nice to see it wasn’t just me :slight_smile:
That’s a good workaroud.
Since my final output will be Excel I’ll copy an Excel template with headers and write to that.

I do hope they fix the bug in the activity though, and that it would be easier to choose columns, e.g. name a SharePoint List view as template.

1 Like