SharePoint activities for Windows compatibility

Hi all,

I am currently using UiPathTeam.Sharepoint.Activities package to connect with MS SharePoint. But this package is compatible only with Windows- Legacy.
Is there any similar package available in the marketplace for Windows compatibility?

Also please help me understand, if I continue using Window-legacy what will be the long-term impact? Is there any chance that UiPath will move away completely from the Window-Legacy framework?

Thank you

Hi @Sundararaman_S1
Use Office365.activities to connect sharepoint

Kaviyarasu N

1 Like

Thanks. I am trying with O365 package, but the activities available for SharePoint, target only the SharePoint Lists. I need to connect with SharePoint Libraries to upload/ download files.

If you have any sample workflows pls do share, it will be helpful.

Thank you!

Hi @Sundararaman_S1
To upload or download files, you use the SharePoint API in this case. Via api you can do lot of activities in sharepoint.

Kaviyarasu N

1 Like


Office 365 package has files and other related activities as well.Please check

And also, if you use windows legacy…in the next release UiPath is completely removing it…so it would be an issue…so you have to move from it


1 Like

As this is a UiPath Labs created activity package, can we expect them to update it to be 64bit compatible? Yes, O365 is an option but at least we cannot jump to that directly, the API is not enabled for our robor users and it can be another hassle with internal IT to get it enabled (if even possbile). I would’ve hoped more proactive approach from UiPath for their own developed custom activity packages…


I agree, this is now a big problem for many organizations that I work with.

totally agree, now my customer totally upset about this issue.

They are not removing Windows-Legacy. At some version of Studio you won’t be able to create new Windows-Legacy projects, but you will always be able to edit and run them.

IMPORTANT: Editing, publishing, and running Windows - Legacy projects will continue to be supported in future releases.

Have you tried the new feed

Is there still no solution for this issue?