SecureString lacks capitalized character when Type Into Secure

Hi folks,

I’m currently helping a client with the incorporation of some bots. I’m trying to teach them best practices such as storing credentials in Credential manager or Orchestrator. This client has no orchestrator available and thus uses Windows Credentials.

Unfortunately, we have come across a frustrating not-understandable error. We have a SecureString variable containing a password.
The password is

Testa431

When we express the SecureString through Type Into Secure into Notepad, the password is correct. Once we type the password into the actual password field, testa431 is typed. In other words, the capital is missing.

Has anyone experienced this problem or similar before? That when a SecureString is typed into a password box, capitalized characters all become small?

Thanks a lot.

Hello, @basvanderpol!

I tried with an web form (https://www.w3schools.com/howto/tryit.asp?filename=tryhow_js_password_val) and it worked as expected: CapitalizedSecureString.zip (14.4 KB)

I’ve seen one case before that the robot was typing too fast for the interface to make the masked character appear, so it was just skipping some characters (which apparently isn’t your problem). This could be solved by increasing the DelayBetweenKeys property a bit.

1 Like