I have been trying to type the user ID in a SAP B1 window but Uipath cannot find the UI Element corresponding to the selectors, despite that are exactly the same, even I cannot repair the selector from the UI explorer beacuse it was validated and highlighted.

Remember, SAP B1 is different that SAP.
B1 is for a small businesses.

the window: I want to type the username:

Both selectors:

Both UiPath and SAP B1 were started as Managers.

Hi @Sergio_Marin,

Welcome to the Uipath community! :smiley:

Have you tried the anchor base activity? Maybe you can use the User ID as anchor.

Yes, I did, but I got the same answer. I also tried Find Element and Native Citrix recording… same answer.

I’m really interested in these kind of bugs, I say bug because at first glance it seems like it should click on such textfield for how you shared your images.

First thing that comes to my mind is using an anchor, but seems like you already tried that and still couldn’t be fixed.

So, I would start by doing some workarounds:

First of, that selector has an idx field, that idx is really unrecommended to work with since it can vary from time to time, I know that in this case, UiPath is looking for the correct idx but you can give it a try but removing it.

Then, did you try with a Type Into activity? I see that you are using a Click activity, if, for some reason you have to Click before typing, try by sending hotkeys. I know that this does not make THAT sense, it should work with all activities… but this bug you are facing its so weird…
edit: you can tick the checkbox ClickBeforeTyying on Type Into activity so you wouldn’t need to click before.