Robot connected/unlicensed. Use of a machine only as an unattended robot

Hello dear forum.
My company has just purchased a licence and I have been asked to configure several machines. One of them will serve only as a server and is where the orchestrator will be installed. So far so good.
I want to configure one machine to work only as an unattended robot. I have created a new Robot Account, the documentation says “Robot accounts are helpful for when you need to run back-office unattended processes that should not be the responsibility of any particular user” and this is exactly what I want.

Then in Tenant > Manage Access I add the robot account. Next in Tenant > Machines I add a standard machine and assign it a runtime.

Now I go to my folder > Manage Access and add both the robot account and the machine in the same folder.


Finally I go to the machine I am going to use as an unattended robot, open assitant and connect it to orchestrator via the URL and machine key.

Thank you all in advance for reading my post. Does anyone know how to solve my problem?

Hi!

please follow the below steps:

1.Signout from studio and UIPath Assistant.
2.Now close studio

I hope you have connected your machine with robot. if not try this.

1.Tenant->Manage Access->Select your account->Edit->Robot Setup->Run Foreground automation

provide the following

Domain/Username

Win+R → TYPE whoami->copy the code and provide it in Domain/Username

Credential store

Orchestrator Database

Password

Your windows password

Credential type

Windows credentials

Then click on save.

Inside the studio:

please follow the below steps:

→ Now open the UiPath Assistant Navigate user Icon ->Preferences->Orchestrator settings->Sign in

this will automatically sign in both Studio and Assistant.

If still persists the issue please let me know

Regards,
NaNi

1 Like

Just to summarize what I see from your post

  1. Created Robot Account in Cloud Portal named RPATRAINING3
  2. Assigned Roles to Robot Account in Orchestrator
    Tenant > Manage Access > Assign Roles > Robot Account
    • Robot Account: RPATRAINING3
    • Roles: Robot
  3. Assigned Account/Robot to Folder GFT
    Folder > Settings > Manage Access > Assign Account/Group
  4. Assigned Machine to Folder GFT
    Folder > Settings > Machines > Manage Machines in Folder > Select selected RPATRAINING3 Standard Machine Template > Update

So the first thing I would do is hover your mouse over the Status message in the Orchestrator Settings Window. This will reveal a more specific error message and help to lead to in the right direction.

For example, I intentionally left one one piece that I think will be your issue but in my case the specific error is “Robot does not exist”

image

So the question I would pose is when you Assigned the Robot a role in Tenant > Manage Access, did you also provide a credential under Step 2 of the Robot Setup? Which is required for non-cloud robots

So now if I review the Robot status again in the Assistant I see another error message in my case. “There are no available licenses on the server”

image

Start with that and let us know what you find.

In addition to that you’ll also want to ensure that you’ve installed the Robot on the machine in an Unattended Mode (aka Register the Robot as a Windows Service), this will occur for you automatically of you selected an Unattended Robot during installation, but if you installed in another mode you’ll need to select the Advanced Options during installation to also have it register as a window service.

The credential that you provide it for an unattended Robot does not need to match the credential of the user you are logged in as if you do not intend to also use it in an attended state (Unless of course the user you are logged in as IS the domain/local credential authorized to log into the specified machine.)

3 Likes

Hi, @THIRU_NANI @codemonkee
I have followed your steps and the problem has been solved! So it was due to the credentials. As you said @codemonkee , the status in assistant was “Robot does not exist”.

Thank you very much for your help

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.