Read Range Index Error

I don’t understand why I’m getting this error:

  • Read Range: the index was out of interval. Must be a non negative value and less than the size of the colection.
  • Name of the parameter: index.

This have no sense, because I’m using the same header and in one Excel works, but in another with exactly the same header not.

Hi @ShadowZ

Can you show what have you passed in Read Range?

Thanks,
Prankur

Hi,
Yes.

Can you please try to run it with excel application scope?

Thanks,
Prankur

Sorry but throws an error saying that the procees is being used. Because first I add the data and then I read again to see the blank values and when I try to read again, this error appears. I don’t understand, becuase then I used another Excel with the same header and works.

Okay you can either close the workbook and read it or you can use excel application scope with property visible as checked and try it.

Also make sure there are no formulas in the excel with broken value, they usually creates problem.

Thanks,
Prankur

I tried with an Excel with more than 80 sheets, but with the same structure on the MB52 and fails. But then when I try with a single excel with only the MB52 sheets works, why?

Can you share that excel if it does not have any confidential data?

Have you tried with removing the data and only with header?

Thanks,
Prankur

Okey, I have good news. I tried as you sayed with excel aplication scope and with read range and don’t say the same error, now says:

  • The column 0 already belongs to DataTable.

It’s a progess.

Okey, Finally I get the result with excel scope and read range. Thnks for the help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.