Read Range error


you can try with that

Working for me so problem with new updates.

1 Like

ok then, so previous package is fine. we will investigate more. thank you

Akshay, can you share the previous version so Others can use Incase if they don’t find.I will try in sometime.Thanks.

Yes …!! Sure :slight_smile:
UiPath.Excel.Activities.1.2.6256.15131.nupkg (102.4 KB)


1 Like

How can I install old Excel package, i have located that but how it can be installed.
Can you please provide steps?

Hi all,

Here are the steps.

  1. Uninstall Previous Package.
  2. Refresh Activity Panel.
  3. Go to Manage package\Available\Local and install.

Before this you have to place that package which you wants to install inside the UiPath/packages(in your installation drive) folder. then package manager will be able to identify it.

Yes of course, but old packages already resides there… So no need to add :slight_smile:

Ok Sir :slight_smile:

I am having the same issue with the excel scope activity. :frowning: But I installed the previous package version and it’s working once again.

1 Like

Even Iäm trying to install old package but still it is showing same error. Again I can able to see new package again.

I did this way:

When you uninstall the New version, don’t restart the studio.

Go to Available–> You should see two Excel Activities —> Install Old one.

1 Like

Hi @aksh1yadav,

I installed this(1.2.6256.15131) version but still i am getting same issue.

Is there any stable version for excel available, where i can avoid this error?


Well there is new version out already so you can use that. have not checked but as per that package description says they have fixed so you can update and use the latest excel package having version 2.0.6361.22986.

and in your case once again check that you have uninstalled that version or not , i mean i guess you have not uninstalled it correctly so it will show the same version 2.0.6333.17728.


thanks for ur reply @aksh1yadav, i have installed it correctly

and it was showing correct version too.

I tried with new version,

and still getting the same issue :disappointed:

Then problem with may be your code. or excel. You can share? it if possible ?

This POC is for my workplace, i don’t have permission to upload any such doc.

While executing that POC again and again, it will work fine for 95% and in other 5% approx it start throwing this error and when i close all project and restart my system PC it will work fine.
Is it because of temp file or something like that?

Now for testing purpose i made a sample project for excel and now it is working absolutely fine.
Any idea about it or any other people faced such issue?

HI @Gertautas and @Rajat

This is a System.NullReferenceException. This is caused by variation in uipath’s package version. I was getting the same exception. Here is my solution.

  1. Go to the Activities Panel in UiPath studio.
  2. Click Manage Packages .
  3. Click Installed option, and then uninstall only excel package.
  4. Restart UiPath studio.
  5. Again go to Manage Packages window. Click Available option. There you can find
    the excel package. Click on Install.
  6. Now go to Update option, there you can see an updation of excel package is available. Click Update.
  7. Restart UiPath Studio.

Note: Make sure your installed excel package version is same as your package (folder) install in c:\ProgramData\UiPath\Activities