UiPath version 2016.2.6274 : Workbook Read Range problem

excel

#1

Scenario:

Workbook read range activity

Current Behavior:

The workbook Read Range activity is throwing out an error when the range is left blank

Expected Behavior:

In Earlier versions, leaving the read range activity blank would mean the entire range is selected

Studio/Robot/Orchestrator Version:

2016.2.6274


#2

Select empty string to read entire work book sheet ,ex: “”


#3

Even this is throwing out the same error. But the excel application scope read range is working with an empty range or empty strings ("")


#4

Even excel read range is not working now after upgrading excel activities. Can someone help me since all production codes are failing due to this behavior.


#5

You can check this thread


#6

Hi,

This is the same error I have been facing. The work around(/Jugaad) is to use the Excel application scope Read Range.


#7

Hi,
Is there a solution for this.


#8

well it has been fixed with next version of that package release. you can update to latest Excel package from package manager :slight_smile:


#9

I am getting the same error “Object reference not set to an instance” with 2016.2.6379 version.
I am using “UiPath.Excel.Activities.2.0.6361.22986” version of excel.


#10

Update Excel package to version 2.0.6382.14545 then give it a try.


#11

Hey Aksh,

Same thing is happening with 2.0.6382.14545 version too.