Read PDF with OCR - Method not found: 'Void BitMiracle.Docotic.Pdf.PdfDrawOptions.set_Format

I have added an activity “Read PDF with OCR” and saving the text using activity “Write Text File”. It is giving me this exception.
I have tried it with Google as well as Microsoft OCR engines, same exception in both cases.
Can anyone help please?

Message: Method not found: ‘Void BitMiracle.Docotic.Pdf.PdfDrawOptions.set_Format(BitMiracle.Docotic.Pdf.PdfDrawFormat)’.

Exception Type: System.MissingMethodException

RemoteException wrapping System.MissingMethodException: Method not found: ‘Void BitMiracle.Docotic.Pdf.PdfDrawOptions.set_Format(BitMiracle.Docotic.Pdf.PdfDrawFormat)’.
at UiPath.Shared.Activities.AsyncTaskNativeImplementation.BookmarkResumptionCallback(NativeActivityContext context, Object value)
at UiPath.Shared.Activities.AsyncTaskNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Any solution of the above mentioned problem?

I am getting same error. Can anyone help here?


I tried to convert PDF into an image (TIFF) but it also gave same error-

17:09:08.5885 => [ERROR] [UiPath.Studio.Shared.Logging.OutputLogger] [25] Export PDF Page As Image: Method not found: 'Single BitMiracle.Docotic.Pdf.PdfCanvas.get_Resolution

I think it’s not compatible with latest PDF version (I have 2020.009.20065). I can’t find the reading Option (Tagged reading order) in Accessibility options in my PDF file. This is an important reading option to be enabled for Uipath OCR to be able to read the pdf. Also, found that BitMiracle has deprecated this function “BitMiracle.Docotic.Pdf.PdfCanvas.get_Resolution” in their latest libraries. So, UiPath may need to upgrade their code to use other method to read the PDF.

I am facing the same issue , found any solution?

Upgrading the package solved this issue for me.