Read PDF with OCR - Method Not Found Error

Hello everyone,

I am trying to read a scanned PDF with the “Read PDF with OCR” activity and I used Microsoft OCR as the OCR engine of choice. I am constantly getting the error that I have provided below:

“Read PDF With OCR: Method not found: ‘BitMiracle.Docotic.Pdf.ImageCompressionOptions BitMiracle.Docotic.Pdf.ImageCompressionOptions.CreateTiff()’.”

I have tried to un-install and reinstall the UiPath PDF activities package and I have the following activities packages installed:


Can you try changing the version of package and check if it works


Hey Anil, I tried downgrading to a lower version, it threw a different error: Read PDF With OCR: The type initializer for ‘UiPath.PDF.PdfReader’ threw an exception.


With the change of pdf version the intelligent ocr also needs to be changed…please change both and see

Alternately try deleting the packages from this folder and redownload them again…looks like few references are not downloaded or are missing



Deleting all packages and reinstalling them helped me fix the error. Thanks for the timely help Anil :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.