RE: HTTP Request: Method not found: 'System.String RestSharp.Extensions.MiscExtensions.AsString(Byte[])'

Above this information which dependencies i have to add. Could you please help me…

Hi @keerthi_arumugam

I made your topic public in case @Des_X would like to give more context how they managed to solve it.

In the meantime, I’d suggest making sure that the Web activity package is properly installed in your project.

I have uninstalled again install the Web Activity package image
but now also throwing same error…

I am having the same exact problem.

Specifically: I’ve added a HTTP Request activity. Just a simple GET. I am certain that the URI is correct, since I’m logging it in the step immediately before the HTTP Request.

I am running Studio Pro 2021.4.1-beta.131. I have installed (and repeatedly re-installed) UIPath.WebAPI.Activities 1.7.0, which appears to contain RestSharp 106.3.1, exactly as depicted above.

And I am still getting the HTTP Request: Method not found: ‘System.String RestSharp.Extensions.MiscExtensions.AsString(Byte)’ error.

Any help would be greatly appreciated.

Here are the properties of the HTTP Request that I’m trying to make. In summary, the only non-default values are the EndPoint (a variable that I’m certain points to a valid page), and the two variables in the output.

Hi @Hawkins_Dale

Any chance you could zip a sample project that causes this issue and attach it here?

Same issue after having upgraded the WebAPI package version…

Any chance you are able to reproduce with a publicly available URL and you could share a zip of a sample, newly created project with us? :slight_smile:
It would help a lot.

Hi I am having the same issue could you help me? Rest Sharp for web activities is already installed. I used the link below.
Request objects  |  Google Pay API  |  Google Developers

GooglePayAPI Project:
https://github.com/google-pay/gpay-live-demo

Hi @johnlester.i.banasihan

Please check again with WebAPI 1.6.0 activity package version.

Hi @loginerror ,

Thank you for your response but unfortunately still getting the same error. Should I try a lower version?

Strange. Does it happen on all API calls or only the one you are performing (i.e. does a simple GET to google.com return the same error)?

@loginerror ,
I tried to input google.com to an endpoint but I’m still getting the same error. by the way right now I am trying to test the Google pay API so I am testing it using UIPath. Are you familiar on How Am going to integrate google pay to UIPath. I hope you can help me. thank you.

@loginerror @Hawkins_Dale @keerthi_arumugam

It’s now working on my end. Check your dependency package, it’s having a conflict on the testing activity package. You need to uninstall this package for you to use the RestSharp on WebAPI Package.

Hi did you find any solution?

Not yet

I solved the problem by Downloading RestSharp and I added the package in Orchestrator in Libraries