HTTP request fail: Method not found: 'System.String RestSharp.Extensions.MiscExtensions.AsString(Byte[])'

I am trying to do a dead-simple HTTP Request. it’s just a plain ol’ GET. No properties other than the target (which I’m dead sure is correct), and a variable in which to store the HTTP status code.

I get this error:

HTTP Request: Method not found: ‘System.String RestSharp.Extensions.MiscExtensions.AsString(Byte)’.

I am using Studio Pro 2021.4.1-beta.131.
The UIPath.WebAPI.Activities I’m using is 1.7.0, which seems to contain RestSharp 106.3.1.
image

I am stumped, and any assistance would be eagerly welcomed.

Hello,

May I know which template from below did you select while creating new process?

Process
Background Process
RE Framework
Test template
e.t.c

BR,
Chaitanya

Thanks for the fast response! The template I used was “Process.”

Can you share the whole dependencies tree for your project?

This is one of those bollocks scenarios where it worked but a package upgrade makes everything go pear shaped… For future info, how do we make sure that packages are backward compatible?

Thank you all for your replies. Downgrading all of the various packages from the “preview” and “beta” versions to the release versions fixed the issue.

It was indeed the bollocks scenario described. The annoying thing is that when I upgraded Studio, it decided I wanted the latest shiniest (least stable) version of everything. I am a simple man, and am happy with boring old regular release versions, thank you.

1 Like

Not nice indeed :unamused:

We would appreciate a small new project with that beta package installed that reproduces the issue.

It looks like it might be some sort of dependency issue, but it’s proved harder to reproduce without a specific project to dissect.

Good day. I’ll try to provide something later but alas the challenge is that it’s an internal URL :-/ Do you perhaps have an external URL that i may use?

Ideally such project would reproduce the issue with a simple GET to https://google.com :slight_smile:

Otherwise, you could use a site such as https://webhook.site/

Hi there. Firstly, apologies for just sending a random statement without providing details.

image

image

image

Can you share what you downgraded too?

I would suggest sticking to the 1.6.0 version of the activity. I can see that the 1.7.0 has been delisted from the feed, which means our team is aware of the issue and will eventually release the updated version of the 1.7.0 package.

I downgraded to 1.6.0, as Maciej suggests above.

Thank you both…

I noticed the following which was still giving me an error. RestSharp >= 106.3.1 is greyed out because UiPath.Testing.Activities has a higher version of RestSharp (106.11.7). It worked once i removed UiPath.Testing.Activities so perhaps it’s causing some sort of clash.

All good though, so much thanks.

1 Like

Thank you! I was able to reproduce the issue and will let our team know.

An update - the latest Testing activity package 1.3.3 resolves the issue.

1 Like