Python script running from uipath error

I am trying to let a uipath robot run a python script by using the code below Python%20uipath

However, after 1 hour the robot stops and gives the following error message:

RemoteException wrapping System.InvalidOperationException: Error loading Python script ---> RemoteException wrapping System.TimeoutException: This request operation sent to net.pipe://localhost/UiPath.Service/ Host_IPythonService_2536 did not receive a reply within the configured timeout (01:00:00). The time allotted to this operation may have been a portion of a longer timeout. This may be because the service is still processing the operation or because the service was unable to send a reply message. Please consider increasing the operation timeout (by casting the channel/proxy to IContextChannel and setting the OperationTimeout property) and ensure that the service is able to connect to the client.

I tried many different things, but without success. Does anyone knows a solution for this?

@ccc1 - Any luck? Just received the same error.

Not sure if you guys managed to find the solution. This is a known issue and Python being an open source activity for UiPath, you can download the code from Git and can change the default timeout to more than 1 hour and keep it running

1 Like

Hi Sunil_kumar, thanks for the advice. I have the same issue in UiPath. May i know what code from Git you are referring to? if i click the download with hyper link, it direct me to the UiPath download page instead. your advice would be much appreciated.