Publishing process error - Publish of Process project to Orchestrator failed. Payload Too Large


Can someone please help?

You may check this article and see if it helps:

Hello @Aakash_Singh_Rawat
The maximum limit of the file is 286 MB. Kindly check your file and delete the unwanted things.

also, refer to this it may help you

Hi @kennbalobalo,

Thanks for sharing, but I cann’t find any UiPathOrchestrator under sites in IIS manager.


Are you using an On-Premise Orchestrator?
If yes, can you login to the On-Premise Orchestrator server, open the IIS Manager → expand the computer name → expand Sites → take a screenshot and provide to us here


Also check this solution Error while publish RE Frame work to Orchestrator - #2 by ClaytonM

Thanks for reply,
No, I’m not using On-premise Orchestrator, I’m simply publishing process from Studio.

Can you open UiPath Assistant → Preferences → Orchestrator Settings → take a screenshot and provide to us.

We need to see the Orchestrator URL (we will understand the type of your Orchestrator in this way)

Here is screenshot attached.

Ok, so you are using the UiPath Cloud Orchestrator.

Can check the size of your project folder? (Open the project folder → right-click → Properties → Size)

Are you having some pictures or documents in your Studio project that are large? If yes, move them outside of the project and retry the publish.

No, there is no size issue, in one machine I’m able to publish it but in client’s end it is throwing the too large error.
Btw just curious about one thing, can we delete previous inactive versions in Orch. to free the space?
would that work?

Can we delete previous inactive versions in Orchestrator to free the space?

Yes, you can do that, but I think this will not solve your issue.

Try this, open the uipath.config file (it is in the UiPath Studio installation folder), look for

<add key="maxMessageSizeInMegabytes" value="10" />

and replace with

<add key="maxMessageSizeInMegabytes" value="50" />

Save the file → open UiPath Assistant → Disconnect your robot from the Orchestrator and reconnect again → Retry the publish