Problems with process when run via Orchestrator / UiPath Assistant but runs ok in Studio

I am having a weird issue. I have built a State Machine process in Studio and when run manually via Studio runs perfectly. I have put lots of logging in my process so I can see exactly what is happening as its running.

I have published the process to Orchestrator and created a process from the package. The package has been assigned to the computer which has the UiPath Assistant and the unattended bot on it.

When I run the package manually via the UiPath Assistant, I get some logging but it is not as per the design:

When I run via studio, the logging is exactly what I have created in the process:

Any ideas why UiPath Assistant would not be running the full process as designed? I can see the pakage on Orchestrator and confirmed that the “main” xaml file is the correct one and has the logging events.

i have the same issue in UIPath assistant. the process runs perfectly in studio but not in assistant. i hope somebody knows how to resolve this. thanks