Problem with UiPath reading formats

Hello,

When I receive an Excel (with an Spanish format) the decimal numbers are separated from the rest by commas (,) (For example: 34,56) . The problem is that when UiPath reads the Excel he changes it for a dot (.) (For example: 34.56).

Is there anyway to change the UiPath configuration in a way that he reads the table with the spanish format?

This also happens with dates.

For example: 20/12/2018 (Spanish format) to 12/20/2018 (English format)

I usually correct the fields using replaces and changing order of digits in the case of dates, but I want to know if there’s an easiest way using the UiPath configuration.

Thanks in advance,
Daniel

I can suggest a work around, before you read the excel using app scope, open the excel, format the columns (Spanish to English), save & close. These steps can be performed in UiPath itself.

Thanks!

That would work if I didn’t want to use the Spanish format in my workflow.

I’m sorry if I wasn’t clear while explaining myself but what I need is UiPath to read the Spanish format from an Excel file that is already in the Spanish format.

Kind regards,
Daniel

Hi @vilardelld

I believe the fast solution is to match your system settings in this window:

The Decimal symbol is the value that gives you the headache and is most likely set as dot instead of a desired comma.

Could you give it a go? Either way, I believe your post contains valuable feedback about the Excel activity package and I will do some research if something can be done about it :slight_smile:

My system is configured within the Spanish system but when it gets the data from the Excel Application Scope it reads it within the English format, I guess it has to be within the compatibility options of Microsoft Excel.

I think I will just use an If + Replace. Thanks!! :slight_smile:

I will look closer into this issue, it is bordering expected behaviour / bug area (depending on the angle one looks at it).

Could you confirm that you are using the latest Excel activity package?

I’m using the lastes Excel activity package, nevertheless, I’m using Excel 2013. Would that be a problem?

Normally not. Could you test it with the workbook excel activities as well? Those should work:

1 Like

Those work!

Thank you :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.